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1 Configuration and management

This section will show you the methods and ways you can use to access the device and specify further settings. You
will find descriptions on the following topics:

m Configuration tools

B Monitoring and diagnosis functions of the device and software
B Backup and restoration of entire configurations

B Installation of new firmware in the device

1.1 Configuration tools and approaches

LANCOM are flexible devices that support a variety of tools (i.e. software) and approaches (in the form of commu-
nication options) for their configuration. First, a look at the approaches.

You can connect to an LANCOM with three different access methods (according to the connections available).

B Through the connected network (LAN as well as WAN—inband)

B Through the configuration interface (config interface) on the rear of the router (also known as outband)

B Remote configuration via ISDN access or modem (analog or GSM with LANCOM Modem Adapter Kit)

What is the difference between these three possibilities?

On one hand, the availability: Configuration via outband is always available. Inband configuration is not possible,
however, in the event of a network fault. Remote configuration is also dependent on an ISDN connection.

On the other hand, whether or not you will need additional hardware and software: The inband configuration
requires one of the computers already available in the LAN or WAN, as well as only one suitable software, such as
LANconfig or WEBconfig (see following section). In addition to the configuration software, the outband configura-
tion also requires a the computers with a serial port. The preconditions are most extensive for ISDN remote configu-
ration: In addition to an ISDN capable LANCOM, an ISDN card is needed in the configuration PC or alternatively,
access via LANCAPI to an additional LANCOM that is ISDN capable.

1.2 Configuration software

Situations in which the device is configured vary—as do the personal requirements and preferences of the person
doing the configuration. LANCOM routers thus feature a broad selection of configuration software:

B LANconfig — nearly all parameters of the LANCOM can be set quickly and with ease using this menu-based
application. Outband, inband and remote configuration are supported, even for multiple devices simultaneously.

B WEBCconfig — this software is permanently installed in the router. All that is required on the workstation used
for the configuration is a web browser. WEBconfig is thus independent of operating systems. Inband and remote
configuration are supported.

B SNMP - device-independent programs for the management of IP networks are generally based on the SNMP
protocol. It is possible to access the LANCOM inband and via remote configuration using SNMP.

B Terminal program, Telnet —an LANCOM can be configured with a terminal program via the config interface
(e.g. HyperTerminal) or within an IP network (e.g. Telnet).

B TFTP - the file transfer protocol TFTP can also be used within IP networks (inband and remote configuration).
The following table shows, how you can use the configuration:

LANconfig Yes Yes Yes Yes
WEBconfig Yes No Yes Yes
SNMP Yes No Yes Yes
Terminal program No Yes No No
Telnet Yes No No No
TFTP Yes No Yes Yes

Please note that all procedures access the same configuration data. For example, if you change the settings
@ in LANconfig, this will also have a direct effect on the values under WEBconfig and Telnet.
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1.3 Searching and configuring devices

@ Always switch on your device first before starting the PC for configuration.

A Router or an Access Point can be configured in the following ways (provided that the model is equipped with the
according interface):

B Via the local network (LAN) @.

B Via the wireless network (WLAN) @, if the WLAN encryption (e.g. WEP) of a device with a wireless interface and
in the configuration PC has been adjusted correctly and/or has been deactivated.

B Via the serial configuration interface @.
B Via a ISDN connection @

o 2] 3] o

1.4  Configuration with LANconfig

1.4.1  Starting LANconfig

Start LANconfig by, for example, using the Windows Start menu: Start » Programme » LANCOM » LANconfig.
LANconfig will now automatically search for devices on the local network. It will automatically launch the setup
wizard if a device which has not yet been configured is found on the local area network LANconfig.

%73 LANconfig [Sswwaad

File Edit Dewvice Wew Tools Help [y

olalx| =BalE el &l skl ElEE 22 e

LAMconfig Marne | Description I Address | Device ek s s e e sy
L-'/,L)LF\NCOM 1811 Wireless DSL 172.23.56.254 Cpen ¢ Al g b b et mbm by
1 wash s i e st el

If the firewall is activated the LANconfig might not be able to find the new device in the LAN. In this occasion
deactivate the firewill whilst the configuration.

Your LANCOM device is equipped with an extensive firewall and protects your computer even if no further
firewall is active.

Find new devices

Click on the Find button or call up the command with Device » Find to initiate a search for a new device manually.
LANconfig will then prompt for a location to search. You will only need to specify the local area network if using the
inband solution, and then you're off.

Once LANconfig has finished its search, it displays a list of all the devices it has found, together with their names
and, perhaps a description, the IP address and its status
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1ol x|
File Edit Device WYiew Tools Help
Solal| ElwlE] sl e Gllwl 22
a LaMconfig Marme I Drescription | Address | Device Status | Progress | ;I
[ ELC_PRP 10.1.1,31 Ok
Ealc-wrls-s201 10,1.10,183 Ok
Ealc-wrls-e316 10.1.10.184 Ok
Elc-wrls-e201-54m 10,1.10.186 Ok
Initernal Eplo-e214-L54ag 10.1.10.187 ok
Elc-e305-L54ag 10.1.10,155 ok
&plc-e310-L54ag 10.1.10,159 ok
'E,:?ILCIEvZI.Internet 10.1.80.125 Ok
@ cCalvin 10.1.50.14%9 Ok
EHobbes 10.1,80.150 Ok
EaWLansry 10,1,80,245 Ok
5 AMay 150N 10.1.80,247 ok
Eyuskssl 10.1.82.100 Ok
w 10.1.140.159 Reading config ... 41472 bytes
'E,:z,llﬁﬂnnnex 10.1.140.160 Ok =
| Date | Time | ame | Address | Message | ;I
@ 1fz9/2004 1044, 1621AnnexE 10,1,140,159 Configuration editing started
@ 1fz9/2004 1044, 1621AnnexE 10,1,140,159 Configuration reading started
@ 12902004 1045, 1621AnnexE 10,1,140,159 Configuration read successfully
P, - [ I .o

The expanded range of functions for professionals
Two different display options can be selected for configuring the devices with LANconfig:

B The 'Simple configuration display' mode only shows the settings required under normal circumstances.

B The 'Complete configuration display' mode shows all available configuration options. Some of them should only
be modified by experienced users.

Select the display mode in the View » Options menu.

El Double-clicking the entry for the highlighted device and then clicking the Configure button or the Device
=1 » Configure option reads the device's current settings and displays the 'General' configuration selection.

The integrated Help function

The remainder of the program's operation is self-explanatory or you can use the online help. You can click on the
'Help' button top right in any window or right-click on an unclear term at any time to call up context-sensitive help.

Management of multiple devices

LANconfig supports multi device remote management. Simply select the desired devices, and LANconfig performs
all actions for all selected devices then, one after the other. The only requirement: The devices must be of the same
type.

In order to support an easy management, the devices can be grouped together. Therefore, ensure to enable 'Folder
Tree" in the View menu, and group the devices by ‘drag an drop’ into the desired folders.

LANconfig shows only those parameters that are suitable for multi device configuration when more than one
device is selected, e.g. MAC Access Control Lists for all LANCOM Wireless Access Points.

#73 LANconfig 10l =|

Device Edit View Tools Help

o Oyl | il sm|vefma] vl @l 22

LaMconfig | address | Status
{1 ADSL CPE 10.1.80.125 Ok,
{21 Branch Offices : 0.1.140.159 ok
{1 Engineeting Configure l
o -
{1 sDsLcrE
{0 wLAN AP oy

Delete |

A

Loads a new firmware into the selected ¢ properties

1.4.2  Switch graphical user interface language

The language for the LANconfig, LANmonitor or WLANmonitor graphical user interface can be set to 'German' or
‘English".
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Generall Startupl Communication  Extras |

2|

— Set up new device

unconfigured device iz found

Q’ ¥ Launch Setup Wizard when a new

i~ External program

General |Alerting|

V¥ Rogue AP Detection activated

V' Rogue Client Detection activated

2|

Application language
’7 Language:

I English - l

Q’T?F Telnet client: Itelnet.exe

SSH client: |

— Automatic retry

Attempts: |1 _|::'
Time interval: |1 _,::' Minutes

—&pplication language

I English - l

LANconfig: Tools » Options » Extras
LANmonitor and WLANmonitor: Tools » Options » General

Language:

1.4.3

LANconfig facilitates the configuration of various devices within a project with a range of functions that can be run
on several devices at once. If the list in LANconfig contains multiple devices, just click on the device of your choice
with the right mouse key to open a context menu offering the following actions:

Project management with LANconfig

"."-rj LANconfig _I_I- jm| ll
File Edit Device WYiew Tools Help
SR EE R E ]
—
{3 LANconfig ame I Description | Address | Device Status | Progress | ;I
ELC_PRP 10.1.1,31 Ok
10.1.10.183 Ok
10.1.10.184 Ok
e 10,1,10,186 Ok
Internal “ca Configure k Enter 110187 ok
= # Check Chrl+FS 1.10.188 ok
Splc-edl0l5 Fmware Upload  Chrl+U 1.10.189 Ok
EmlC1621.Ink 1.80.125 ok,
Epcalvin Open Telnet Session Chrl+T 1.80.149 ok
pHobbes Monitor Device Chrl+1 1.80.150 ok
EpWLansry Set Date/Time .. 1.50.245 ok
E9AMay_ISON  Delete Del 1.80.247 ok
?Yueksel Cancel Actions 1.82.100 ok

m Configure: Opens up the LANconfig configuration dialog for the selected device
B Check: Checks if the selected device can be contacted

B Firmware upload: Uploads firmware simultaneously to all selected devices

B Apply Script: Applies a configuration script to all selected devices
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%% LANconfig - Branch_offices 1Ol x|
File Edit Device WYiew Tools Help
sl ol milalE| /6| wis sl alals 00
|_ 1 LaNconfig ame I Address I Device Status | Progress |
{3 Branch_offices ) ¥ 10.1.202,192 Uploading Firmware . 53% (AEI6E Byhes/s)
10,1.202.193 Uploading Firmware . 58% (69240 Bytes/s)
10,1.202.194 Uploading Firmware . 58% (55022 Bytes/s)
10,1.202.198 Uploading Firmware 57% (43670 Bytes/s)
10,1.202.199 Uploading Firmware 53% (68675 Bytes/s)
10.1.202.210 Uploading Firmware . 59%. (70285 Bytes/s)
10,1.202.211 Uploading Firmware . 53% (52147 Bytes/s)
10,1.202.213 Uploading Firmware 58% (53007 Bytes/s)
10,1.202.217 Uploading Firmware 56% (52525 Bytes/s)
10.1.202.218 Uploading firmware , 32% (21644 Bytes/s)
10.1.202.219 Uploading Firmware . 46% (53706 Bytes/s)
10,1.202.220 Uploading Firmware . 58% (50486 Bytes/s)
10,1.205,137 Uploading Firmware . 42% (66901 Bytes/s)
10,1.206,211 Uploading firmware . S54% (62541 Bytes/s)
| Date | Tirne | Iame | Address | Message |
(L 27.01.2004 10:383:00  LEIPZIG 10.1.202.218 Firmware upload started
(i) 27.01.2004 10:38:00  TEMPELHOF 10.1.202.219 Firmware upload started
(i) 27.01.2004  10:38:00  MERSEBURG 10,1.202.220 Firmware upload started
(i) 27.01.2004  10:38:00  WITTEMBERG 10,1.205,137 Firmware upload started
@ 27.01.2004  10:35:00  ANGERMUEMDE 10.1.206,211 Firmware upload started
() 27.01.2004  10:38:00  CHEMMITZ 10.1.206.212 Firmware upload started
(i) 27.01.2004 10:38:00  ADLERSHOF 10,1.206.213 Firmware upload started
| 4
#% LANconfig - \Branch_offices =1of x|
File Edit Dewice ‘ew Tools Help
sl oy milwlE| oo sl k] elslel 203
D_LANT mDevi:e Status | Progress
43 Branch_offices 101,202,192 Uplogding Frmware . ERENEN 5% (5965 Bytesis)
- Clentot 10.1.202.193 Uploading firmmware . 5a% (59240 Bytes/s)
3 Clentoz 10.1.202.194 Uploading firmware . 5a% (55022 Bytes/s)
@ meemal 10.1.202,198 Uploading firmware . 57% (43670 Bytes/s)
10.1.202.192 Uploading Firmware . 53% (6B675 Bytes/s)
10.1.202.210 Uploading firmware . 59% (70285 Bytes/s)
10.1.202.211 Uploading firmware . 53% (52147 Bytes/s)
10,1.202.213 Uploading firmware , 55% (53007 Bytes/s)
10,1.202.217 Uploading firmware,  WINNEEE  569% (52525 Bykes/s)
10.1.202.218 Uploading firmware ., WOOE 32% (21644 Bytesjs)
10.1.202.219 Uploading Firmuare . 46% (53706 Bytesjs)
10.1.202.220 Uploading Firmware . S8% (50486 Bytes/s)
10.1.205.137 Uploading firmware . 42% (66901 Bytes/s)
10.1.206.211 Uploading firmware 54% (62541 Bytes|s)
| Date | Time | Mame | Address | Message
(i) 27.01.2004 10:3:00 LEIPZIG 10.1.202.218 Firmware upload started
(i) 27.01.2004 10:38:00 TEMPELHOF 10.1.202.219 Firmware upload started
(i) 27.01.2004 10:3%00 MERSEBURG 10.1.202.220 Fitmware upload started
(i) 27.01.2004 10:3%00 WITTENEERG 10,1,205,137 Firmware upload started
(i) 27.01.2004 103500  ANGERMUENDE 10.1,206,211 Fitrmware upload started
(i) 27012004 10:3%00  CHEMNITZ 10,1,206,212 Firmware upload started
(i) 27.01.2004 10:3%00 ADLERSHOF 10.1.206.213 Firmware upload started
| | 4

B Open Telnet session: Opens up multiple DOS windows and sets up a Telnet connection to each device
B Monitor device: Starts LANmonitor for the surveillance of the selected devices
B Set date/time: Sets the same time on all selected devices.

When setting the time, please observe the functions of the LANCOM as NTP client and NTP server ('Time
@ server for the local net” — page 672).

B Delete: Deletes the selected devices from the LANconfig list.

1.4.4  User-specific settings for LANconfig

The program settings for LANconfig are saved to the file ‘lanconf.ini' located in the program directory when the pro-
gram is ended. This includes, among others, the displayed devices, directory structure, selected language, etc. When
the program is started, LANconfig reads this ini file and restores the previous status of the software. To save the ini
file, the user needs a write authorization to the program directory.

As an alternative to the .ini file in the program directory, the program settings can be read from another source. The

current user's user directory can be chosen, or indeed any other lanconf.ini from any location:

B By selecting the user directory, users can save their personal settings even if they don't have a write authorization
for the program directory.
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B Selecting an alternative storage location can be used, for example, to transfer program settings to any other
LANconfig installation, or to save the program settings to a central location in the network for use by multiple

users.
options 2| ]
General I Startup I Communication Application | Extras I
 Startup
Windows startup: Istart LANconfig like before j
r Language

Dialog language: I English - l

r— Program settings

™| Use user specific settings

V' Use configuration file:

IC:"-.Docoments and Settingsfnhamel\E Browse... |

LANconfig: Options P> Application
B Use user-specific settings

Activates the use of the lanconfini file in the current user's directory ..\User\Application
Files\LANCOM\LANconfig.

With this option activated, changes to the program settings are saved to this ini file.

O Possible values: On/off
0O Default: Off

If this option is activated in parallel with the 'Use configuration file' option, then the file selected here will
be used when the program starts and changes made to the program settings are stored to it.

B Use configuration file
The activates the usage of the lanconf.ini from the given directory.

With this option activated, changes to the program settings are saved to the ini file selected here.

O Possible values: On/off and selection of the settings file
O Default: Off

@ The file you select must be a valid LANconfig settings file.

@ If neither of the two options is activated, the ini file from the program directory will be used instead.

1.4.5 Customizing the toolbar

To customize the toolbar, select the following options in LANconfig under View » Toolbar:
B Standard buttons: Hides/displays the buttons.

B Llarge icons: Shows a larger view of the icons.

B Show text: Text describing the action is displayed under each icon.

P?'.;»'jL.l\I“«:onfig
File Edit Device WYiew Tools Help

S 0 E1 Ee ‘ &

Add Search Delete Properties Lp Folder Tree

B Customize: Opens up a dialog enabling the displayed icons to be selected. A separator can be inserted between
groups of icons. The order of the icons can also be changed.
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Customize Toolbar

Ayailable toolbar buttons: Current toolbar buttons:

Separator I;I @ Upload Firmware ;I

Q Firmweare Update Check

Add - | g Firmweare Update Check Al Help

Separator

<- Bemove | @9 Options
@ Help

Lloze

Feset

Move Up

L bl

ove Down

B Reset: Resets the settings for the toolbar to the default values.

1.4.6  Automatic backup of configuration with LANconfig

LANconfig can automatically save backups of the current configuration prior to changes in firmware or configura-
tion. Global settings to be used for all devices are available under Tools » Options » Backup. Additionally, special
backup settings can be defined for individual devices. To access them, right-click the appropriate device and select
entry Properties » Backup from the context menu.

Select the following options here:

B Are the global or the device-specific backup settings for this device to be used (in device-specific dialogue only)?

B The event prior to which the configuration is to be saved (firmware upload, configuration change or script exe-
cution).

B In which format the configuration is to be saved (configuration file, script - possibly with options).

B In which directory the configuration is to be saved.

B How the file name of the backup file is to be structured. Placeholders can be used for device information (IP

address, hardware type, etc.) and time information. Please refer to the online help function for further informa-
tion on placeholders.

General I Startup I Communication I Application  Backup | Extras I General Backup | VPN I Infarmation I
- Device configuration - Device canfiguration
% Make an automatic backup of the current device N [ Use device specific backup settings
@ configuration: @
[V before uploading a fimware Make an automatic backup of the current device

X . X configuration:
[V before changing the configuration . .
~ ¥ | before uploading & fitmweare:
v before applying a script . . .
pryna e ¥ | befare changing the configuration

— Backup option

¥ | befare applying & soript

V' Save as configuration file

— Backup option

I” Save as configuration seript ¥ | Save as configuration file

¥ | Hureric ¥ | Camments s furati o
¥ Default parameters ¥ Compact Wz as c:.on LR SEE
¥ Colurmn names ¥ | Hureric ¥ | Camments
¥ Default paramete ¥ Compact
Backup path: ¥ | Calumn names
IE:\Dokumente und Einztellungen‘uwmich Browse... | Backup path:
Backup filename [without extension]: IE:\Dokumente und Einztellungentismmi Browse... |

|\°/°y_°/°mn_°/°dn\°/°N_°/°G_°/°F[1 -4]_Fhh-Emm-Es

Backup filename [without extension]:

|\°/°y_°/°mn_°/°dn\°/°N_°/°G_°/°F[1 -4]_Fhh-Fmm-s

()8 I Abbrechen

()8 I Abbrechen

1.4.7  Directory structure
LANconfig uses a directory structure for a clear overview when managing multiple devices. Folders dedicated to pro-
jects or customers can be set up to organize the relevant devices:

B Create a new folder by clicking on the parent directory with the right mouse key and selecting "New Folder" from
the context menu.

B Just use the mouse to drag and drop the devices into the appropriate folder. Devices can also be moved from
one folder to another in this way.

The arrangement of devices in folders effects only the display of the devices within LANconfig. The organi-
@ zation of the folders has no influence on the configuration of the devices.
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=10l x|
File Edit Device WYiew Tools Help
Sl || G|l sl slseles| el el
a LaMconfig Marme I Drescription | Address | Device Status | Progress ;I
ELC_PRP 10.1.1,31 Ok
Ealc-wrls-s201 10,1.10,183 Ok
Ealc-wrls-e316 10.1.10.184 Ok
Elc-wrls-e201-54m 10,1.10.186 Ok
Eplc-s214-L54ag 10.1.10.187 ok
Eplc-ea08-L54ag 10.1.10.188 ok
Eplc-e310-L54ag 10.1.10.189 ok
EmLC1621 . Inkernet 10.1.80.125 ok
@ cCalvin 10.1.50.14%9 Ok
EHobbes 10.1,80.150 Ok
EaWLansry 10,1,80,245 Ok
i AMay_1SDN 10.1.80.247 ok
Eyuskssl 10.1.82.100 Ok
w 10.1.140.153 Reading config .. 41472 bytes
ESEESPRMS = LaNconfig -
| | | File Edit Device WYiew Tools Help j
Date Time Mame - - o o
@ 1/29/2004 L1044, 16218nnexE DlE E‘;ﬂ@ il%lﬁ
@ 1/29/2004 L1044, 1621AnnexE Ig:me
@ 12902004 1045, 1621AnnexE le-warls-e201 ¢
@ 1/29/2004 1055,  1621AnnexE {8 ] Ciierto- mrls-e316 |
(T 1292004 L0&il..  1621AnnexE erlsﬂﬂl-s‘?m
@ 1/29/2004 106, 1621AnnexE Fz  [E2l4-L54ag -
| 'e308-L54ag
&alc-e310-L54ag £
EaLC1621, Inkernet
ﬁr.l..._
The directory structure in the left margin of the LANconfig window can be switched on and off with the F6
function key or by using the menu View » Folder Tree.
1.4.8  Better overview in LANconfig with more columns

Even for large-scale projects, a better overview and quicker orientation are facilitated in LANconfig by the columns
featuring device-related details that can be displayed or concealed according to your needs. Simply click on the
column header with the right-hand mouse button and use Select columns. The menu item Arrange icons allows
you to sort the items as you prefer.

The following details can be displayed in the various columns:

Device name
Description
Address

Device status
Progress

Device type
Hardware release
Serial number
MAC address
Firmware version (active)
Firmsafe

1. Image version
2. Image version
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=1l
Fle Edt Device Vew Tools Help
saxEcElsHsHE@ ERTaElean 2R
F Laticonfin Name & Desc... | Address ] e | I Tr T serisl Nomher | MAC Address | Firmware Version | Firmsafe [ 1. Image Version [ 2. Image version |
20 @home | ghane Crdrer View v View v — N
15
= (Cd@kollegen  Ordrer e v [r—— vl
@Kollegen .
((d@webinar  Ordner v Name
Bsbnar | 10,11 A 17.03.2008) {aktiv)
«ppp -1:1 " show grid lines v Desaiption Show grid lines v Desaription == d
SBRouter123 1002 Jine up Teons + Address ppespeeuses e 17.02.2008) (ahtiv)
pRouteried w1z  Device Status - P 27.03.2008)
SpRouter1 18 10.1,2  AddDevice... IS Progress :  AddDevice... e 14.02.2008)
Find Devices... F3
Routeries w1z + Device Type ¢ Find Devices... S i 14.02.2008)
SaRouter 26 1012 check all Devices Fs v Hardware Release * " Check Al Devices = o 17.02.2008) (aktiv)
SpRoucer12? 10:2:2 Update Al Devices with Firmnare w Serial Number Update All Devices with Firmware v Serial Number 16.02.2008)
SRouter120 18.1.2 el Actions « MAC Address P — » MAC Address 17.02.2008] (aktiv)
pRouteriee w1z v Firmware Version e —— .02.2008)
pRouter121 10.1.2 e e T v FirmSafe Tiew Group Corfiguration. . -y 14.02.2008)
A Group ConFiguration ..
pRouter11s 10.1.2 roup Confiauration o — A Group ConFiguration .. i 17.02.2008) (akiiv)
‘ ]| Spten pee.. 10.1.1 v Tmage 2 G 17.03.2008) (akite) =]
(-] T address [ Message Restore last vien
Hide all
[2 Device(s) [ v

1.4.9  Multithreading

The management of larger projects can be aided by simultaneously opening up configuration windows for multiple
devices to compare similarities and differences. LANconfig allows multiple configuration dialogs to be opened at the
same time ("multithreading"). After opening the configuration for a device, simply open up further configurations
from the device list in LANconfig. All of the configurations can be processed in parallel.
Ioix

File Edit Device View Tools Help

ol mlwlE] il slnla] wlwlal el

LaNconfig Description | Address [ Device Status [ Progress | -]

{1 client e 1621 Annexs 10.1.140,160 Open Config Dialog
=2 Clientoz 10.1.140,159 Open Config Dialog 40950 bytes

(03 officen =% AMay_[SDN 10.1,80.247 ok
(3 officenz S Calin 10.1.80,149 ok
0 meernal &Hobbes 10.1.80,150 ok
SALC1621. Inkernet 10,180,125 ok
AL _PPP 10.1.1.31 ok
EALC_RAS 111,12 ok
EPLC_YPN_M_LCSTEST 10.1.1.10 ok
—— - HOME 192.165.2.100 Ok
1621 AnnexB Configuration 21x%| 10.1.50.245 ok
O w1200 ok
E4ag 10.1.10,187 ok
General | Intertaces | Secuity| Casts | Féag i ok
E4a 10.1.10,189 ok

[ add - T |
i i 7| x|
3 — FTg| 2L AnnesA Configuratian 21x]
Admiristrator 107 Configure: [ Management k =
k. 1o banagement
] 10.. Genersl | jnfDale & Time
10, Log & Trace

Commumication

1621 Arnewd,
E.210
GReichel

Ny K1

Device type: LANCOM 1621 ADSLASDN
Hardware release: A

Firmusare vession: 3.30.0031 / 26 M.2004
Serial number. 859530980220

Device type: LANCOM 1621 ADSLASDM
Hardware release: A

Firmusare vession: 3.30.0031 / 26.01.2004
Serial number. 089540203081

LANCOM
[l |

ganean Coree

"Cut and paste" can be used to transfer content between the configuration windows via the Windows clip-
board.

Multithreading allows changes to both the internal configurations of the available devices and to the configuration
files. Each configuration is written separately to the file and to the device when the dialog is closed.

1.4.10 Manual and automatic searches for firmware updates

To make the update of LANCOM devices with new firmware as convenient as possible, the firmware files for the
various LANCOM models and LCOS versions are, ideally, saved to a central archive directory. The search for new ver-
sions of the firmware in this directory can either be initiated manually or automatically after starting LANconfig.
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Automatic search for firmware updates

The directory where LANconfig is to search for the updates is set under Tools » Options » Extras. It is also possible
to set up LANconfig to search the firmware archive and to check if any of the devices found require an update. With

this option activated, starting LANconfig automatically displays all of the devices for which new updates are avai-
lable.

General  Startup | Windows I Extras I Firmware update x|
W Search for new devices at statup—————— 6 Firmware updates for your devices have been found during the
X Q’ aukomatic update scan in the Following directory:
¥ i the local network,

[:\ProgrammeiLANCOMILANConfighFirmware

|3 _,::' seconds

. . Do you like to select the devices ko be updated now?
[ in the following remate netwarks ¥ e

fes Mo

13 =| seconds |

Ad

L=
Edit... | | |

Firmware update =
Femave |

Select the devices to be updated:

v Scan fimware archive at staftup —————————————

|
s

Cancel |

Archive: ID:\Programme\LANEDM\LANconfig\Firm j & LANCOM DSLJI-1611 Office: 3,52 (21.09,2004) -> 4,00 (26.11,2004)

WI\Eheck devices for pozzible firmware updates

Manual search for firmware updates

To search manually for firmware updates, click with the right-hand mouse key on a device marked in the list and
select the following point from the context menu: Firmware management »Check for firmware update. If you

wish to update several devices simultaneously, the entry Check for firmware updates is displayed directly in the
context menu.

lolx]
File Edit Device WYiew Tools Help
N = - LANCOM
ol oyl ml@lE| Sl vlwilsl Elwwlal s 22 o ——
Mame Description Address Device Status Progress |
Confi E ‘I:HH‘MH oo Ok
GALANCOMD  onaure ner o ok
Setup Wizard Chrl+iw
Check Chrl+FS
Configuration Managenent 3

Fitrnware Management Check for Firmware Update

WEBConfig | Console session 3 Upload Mews k TWare Chrl+l

Monitor Device Chrl+M
Set DatefTime ...
Activate Software Option I

1 Yersion 4,00 of 26,11,2004
® 2 Yersion 3,52 of 21.09,2004

View a full list of all firmware versions

If your search in the archive did not reveal a new firmware version, you can alternatively view a full list of all of the
firmware files that have been found. You can, for example, switch back to an older version. LANconfig displays all
versions found for the marked devices, including the version currently active in each device. For each device, you can
select precisely one firmware version that will then be uploaded onto the device.

Firmware update =

Mo newer firmware was found in the selected archive director
Q’ [:\ProgrammeiLANCOMILANConfighFirmware Firmware update 1'

For the Following devices firmwares were Found:

‘Would you like ko view the Found firmwares anyway?

[] &3 WPI_NHAMEL: 4,00 (26,11,2004) -> 3,52 (21,09.2004) Update h

[] &3 WPI_NHAMEL: 4,00 (26,11,2004) -> 4,00 {25.11,2004)
._ Cancel |

9 & VPN _NHAMEL: 4,00 .
& LANCOM DSL{T-1611 OFfice: 4,00 (26,11,2004) -> 3.52 (21,09,2004)
[ €5 LANCOM DSL{I-1611 Office: 4,00 (26.11,2004) -> 4,00 (26,11,2004)

fes

s

1.4.11 Password protection for SNMP read-only access.

The read-only access to a LANCOM device via SNMP—for example with LANmonitor--can be password protected.
This uses the same user data as with access to LANconfig. Password protection of SNMP access means that the user
data must be entered before information about the device status, etc. can be accessed over SNMP.
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LANmonitor User information can be entered in LANmonitor separately for each device. To do this, click with the right-hand
mouse key on the required device, select the Options point from the context menu and enter your user data.

General | Advanced I

 Information
Device: LANCOM 1817 Wireless DSL
Q’ Wendor: LAMCOM Systems GmbH

IP address: 1921682100

— Authentication

Q,-' Enter pour configuration access data for the
| device here.

Adrninizstratar: localadmin|
Password: IF

Mote: The administrator may only be specified if
an administrator account has been configured in
o s

Access rights in LANmonitor depend on the rights possessed by the user:
B Asupervisor has full access to the information in LANmonitor and can execute actions such as closing a connec-
tion, among others.

B Alocal administrator also has full access to the information in LANmonitor and can execute actions such as clo-
sing a connection, among others.

B Auser with read-only rights can view the information in LANmonitor but cannot take any actions such as closing
a connection.

B A user without rights has no SNMP access to the device's information.

45 YPN_NHAMEL Configuration 2=l
Configure: IManagement 'l

Generall Interfacesl wireless LAN  Adrmin |Eosts I WLAN I

Device Configuration

Mumber [MSH]: I

Further Administratars ... |

phPassword required for SMMP read permission

|— Eor}?iguration login lock |

LANconfig: Management » General
WEBconfig: LCOS menu tree » Setup » Config modul» Password-required-for-SNMP-read-access

1.4.12 Device-specific settings for communications protocols

With LANconfig, all device actions are conducted using the TFTP protocol. Since this protocol has disadvantages
compared to other protocols when transmitting large volumes of data, the protocols HTTPS and HTTP can also be
used as alternatives.

The use of the protocols can be set either globally for all devices managed by a LANconfig or specifically for each
individual device. The global settings overwrite the specific settings here — therefore, in the specific device settings,
only the settings allowed in the global configuration can take effect.

Configuration of the global communication settings

When setting up the communications protocols, one must differentiate between the protocol that is used solely for
checking the device and for other operations such as a firmware upload, etc.:

options _______ (x|

Generall Statup  Communication | Extras I

— Metwork

[~ Always clear &8RP cache before IP commurication

r~ Pratocaol
IV HTTPS [ HTTP ¥ TFTP
[V Prefer ‘check' via TFTP [faster]

LANconfig: Tools » Options » Communication
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B HTTPS, HTTP, TFPT

When this is selected, the individual protocols are enabled for the operations firmware upload, configuration up/
download, and script up/download. In these operations, LANconfig attempts to use these protocols in the order
HTTPS, HTTP and TFTP. If the transfer fails when using a selected protocol, then the next protocol is automatically
attempted.

m Prefer checks via TFTP

When checking the devices, only small amounts of data are transferred with the system information. As such,
device checks could be performed using the TFTP protocol, particularly in the LAN. When this option is activated,
the TFTP protocol is used to check the device first, regardless of the previously set communications protocols. If
the check via TFTP fails, then the protocols HTTPS, HTTP and TFTP are attempted in that order.

The device-specific settings are subordinate to the global communications settings. This allows, for example,
@ the use of a protocol to be restricted centrally.

Configuration of the specific communication settings

For configuring the specific communications settings, the properties dialog of a device is opened via the context
menu (right-click on mouse):

2|

General |

~ Interface

Q% " Network connection [TCP/P)
= " Serial part

' DialUp connection

Fhone numnber: I VI
Hang up after |2D _|::' zeconds

I | Check the status of this device at startup
™| Search and update fimware. at startup

Communication protocols and ports:
IV HTTPS [ HTTP ¥ TFTP

[ [

[V Prefer ‘check' via TFTP [faster]

B HTTPS, HTTP, TFPT
Select the communications protocols as described in the global settings:
In the fields under the protocols, the port to be used can be entered using the following default values:
0O HTTPS: 443
0 HTTP: 80
0 TFTP: 69
B Prefer checks via TFTP
Preferred checking via TFTP as described in the global settings.

For all specific communications settings, the global settings are considered to be superordinate. A protocol
@ can therefore only be used for operating a device when it is also activated in the global settings.

1.4.13 LANconfig behavior at Windows startup

LANconfig can be automatically started when the operating system starts.

Configuring the behavior of LANconfig at startup

The following parameters are used to configure the startup behavior of LANconfig:
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2|

Generall Startupl Communication  Application | Backupl Extrasl
— Startup
Windows startup: Istart LAM config newver j
— Language

Dialog language:

— Program setting:
™ Use user specific settings

™| Use configuration file:

I Browse,.. |

LANconfig: Options » Extras » Application

B Windows system startup

O Start LANconfig never: LANconfig does not start automatically with the operating system, and it has to be

started manually.

O Start LANconfig always: LANconfig always starts automatically after Windows starts successfully.

O Start LANconfig like last time: LANconfig starts in the program in the same status as when Windows was
shut down the last time: If LANconfig was active then it will be started again; if inactive, LANconfig will not

be automatically restarted.

When changing to a setting that enables LANconfig to be started automatically, an change is made to the

@ operating system's registry. Personal firewalls on the computer or the operating system itself (Windows XP
or Windows Vista™) may interpret this change as an attack and may issue a warning or even prevent the
entry from being made. In order for LANconfig's startup behavior to be controlled as desired, you can ignore
these warnings and allow the changes to be made.

1.4.14 Choice of Wizard or configuration dialog

You can define how LANconfig reacts when an entry in the list of devices is double-clicked, i.e. whether a Setup
Wizard or the dialog for manually editing the configuration appears.

General I Startup I Communication Exras |

2|

 Set up new devices

¥ Launch Setup Wizard when a new
unconfigured device is found

r— Edit Configuration

£ se Wizard as standard

' Edit manually as standard

)

A

The standard behavior of LANconfig can be set under:

LANconfig: Tools » Options » Extras
B Editing the configuration

O Use Wizard as standard: Double-clicking on a device entry in LANconfig will open up a dialog offering a
choice of Wizards. As an alternative, the option '‘Manually edit the configuration' can be selected here.
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P?'.;»'jl.ﬂllcnni"lg ;IEI
File Edit Device View Tools Help
@|Q|Q.| = u;s|§5| g;,“::.-m @|g~a| E’@Imlml e T e M o |

=T - = x|
B A\onic I I -

&1 ANCOM 1811 Wireless DSL Setup Wizard

This wizard lets you configure your device for specific
applications quickly and easily.

What do you want to do?

&3 Manually edit the configuration -

~ Check security settings
:g{ Set up Intemet access
:g{ Provide remote access (RAS, VPN, IPSec over WLAN)
:g{ Connect two local area networks (also VPN)

%% Remove remote site or access
4 i s firsusll

Edit manually as standard: Double-clicking on a device entry in LANconfig will open up a dialog for editing the con-
figuration manually.

1.4.15 WLAN configuration with the wizards in LANconfig

Highly convenient installation wizards are available to help you with the configuration of LANCOM Access Points for
your wireless LAN.

The settings include the general shared parameters and also the individual settings for one or more logical wireless
LAN networks (WLAN radio cells or SSIDs).

(1 Mark your LANCOM Access Point in the selection window in LANconfig. From the command line, select Extras
» Setup Wizard.

[ |
Setup Wizard

This wizard lets you configure your device for speciic
applications quickly and easity.

What do you want to do?

[ Manually edit the configuration -

%%, Set up Intemet access
+<_Configure WLAN

%, Provids remote accass (RAS, VPH)
%, Connact two local area networks (VPN)
%, Remove remote site or access

(@ Inthe selection menu, select the Setup Wizard, Configure WLAN interface and confirm the selection with Con-
tinue.

(3 Make the settings as requested by the wizard and as described as follows.

Country settings

Regulations for the operation of WLAN cards differ from country to country. The use of some radio channels is pro-
hibited in certain countries. To operate the LANCOM Access Points while observing the regulations in various coun-
tries, all physical WLAN interfaces can be set up for the country where they are operated.

WLAN module operation

The WLAN modules can be operated in various operating modes:

B As a base station (Access Point mode), the device makes the link between WLAN clients and the cabled LAN.
Parallel to this, point-to-point connections are possible as well.

B In Managed Mode the Access Points also accept WLAN clients into the network, although the clients then join
a WLAN infrastructure that is configured by a central WLAN-Controller. In this operating mode, no further WLAN
configuration is necessary as all WLAN parameters are provided by the WLAN-Controller.

B In client mode, the device itself locates the connection to another Access Point and attempts to register with a
wireless network. In this case the device serves, for example, to link a cabled network device to an Access Point
over a wireless connection. In this operating mode, parallel point-to-point connections are not possible.

For further information please refer to section — Client Mode.
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Physical WLAN settings

Along with the radio channels, the physical WLAN settings can also be used to activate options such as the bunde-
ling of WLAN packets (TX Burst), hardware compression, or the use of QoS compliant with 802.11e. You also control
the settings for the diversity behavior here.

Logical WLAN networks

Each WLAN module can support up to eight logical WLAN networks for mobile WLAN clients to register with. The
following parameters have to be set when configuring a logical WLAN network:

B The network name (SSID)

Open or closed radio LAN

Encryption settings

MAC filter

Client-bridge operation

Filter settings

Point-to-point settings

The configuration of P2P connections involves setting not only the operating mode but also the station name that
the Access Paint can connect to. Also, the role as "Master" or "Slave" is set here.

Along with the settings for the Access Point itself, also to be defined is the remote site that the Access Point can
contact via the P2P connection.

For further information please refer to section — Point-to-point connections.

1.5  Group configuration with LANconfig

When managing multiple devices it can be very helpful to upload a selection of configuration parameters into a
group of devices at once, as opposed to setting each and every parameter manually in the individual devices, e.g.
with identical client rights in WLAN access points. Importing complete configuration files is not a viable alternative
since device-specific parameters such as the IP address are uploaded as well. Group configuration with LANconfig
enables the easy import of partial configuration files and thus makes the simultaneous administration of multiple
devices a reality.

The partial configuration files with the common parameters for a group of LANCOM devices are, just like the full
configuration files, stored on hard disk or on a server. To aid the configuration of entire groups of devices, links to
the partial configuration files are created under LANconfig to provide a convenient connection between the device
entries in LANconfig and these partial configuration files.

@ Group configuration is supported only by LANCOM devices with a firmware version LCOS 5.00 or higher.

LCOS version 5.00 initially support the group configuration of WLAN devices. Later firmware versions will
also support further types of group configuration, such as the VPN parameters. Refer to the LANCOM web
site www.lancom.de for more information about the latest firmware versions and the additional possibilities
of group configuration.

1.5.1  Create a group configuration

A requirement for working with group configuration to the grouping of devices within folders. These LANconfig fol-
ders contain those device entries which are effectively managed by common partial configurations, and the group
configurations as links to the partial configuration files.

Group configuration with a new partial configuration file
(1 Create a new folder and move the devices that are to be grouped into it with the mouse.
(2 Then click on the folder with the right-hand mouse key and select the entry New group configuration... from

the context menu. After selecting the group type and the firmware version, the LANconfig configuration dialogue
opens up with a reduced selection of configuration options.


www.lancom.de
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7% LANconfig - \WLAN ] 3]
Fie Edt Device Wiew Tools Help
5 =TT = LANCOM
ol mlElE| el ol sl el wluh e — :
= = i i i ?|x
|1 Lanconfig Mlamme Description [ Address [ Devics Status New Configuratmn forLAHESERSES [% Il [
Hew Folder e 1611 Office 192.168.2.100 Ok Configue:  [imottaces =]
Bt B 192.168.2100 Ok :
Rename Fz Wireless LAN |VLAN ]
Add Graup Canfigurati \ This is where pou can make settings for all wirslsss LAM
EE— New Group Configuration File 2l interfaee in comman
% Select the group that you want to create a new group Country: [Unknown —— |d
W@ | configuration Fle for.
¥ AP handing
Group: T Broken LAH ik detsction
Firmuare version: |5.00 - f——
Software options: [ Public-Spot This is where you can make futher settings for your physical
witsless LAN intetace
b Physical WLAN seftings =
Date Tirne Marme I This s where pou can make further settings for each lagical
@ 6l6fz005 Sz WPN_HHAMEL e witsless LAN netwark (MuliSSID)

(3 The parameters here should be set as required for the entire group. When the configuration dialogue is closed,
LANconfig will request that you save the partial configuration file to a location of your choice.

The group configuration then saves all parameters to a partial configuration file. Those parameters which
were not changed are also set to the standard values. Use the scripting function ('Scripting’ — page 91) to
read out non-standard settings from a device and transfer them to other devices, if required.

@ The link to the partial configuration file appears in the list of entries and has the description 'Group Configura-
tion'. The name of the group configuration can be changed via the Properties. To do this, click on the entry with
the right-hand mouse key and select Properties from the context menu.

=1l
File Edt Device Wiew Took Help

ol wilmlE el Sl Elal s aldlnl 2]
|1 Laniconfig Hame Description Address | Device Status [ Progress
: EELANCOM Group Wireless 5.00 | Group Configuration

EsILANCOM DSLJ1-1611 Office 192.168.2.101  Group update recommended
S VPN _NHAMEL 192,165,100 Group update rscommended

Group Configuration Properties 21x|

General | Informatian |

=| Description:  |Group Canfiguration]

The group configuration is a link to the partial configuration file. Please note that changes to the partial con-
figuration file will lead to changes in that group configuration.

Use an existing partial configuration file

There are cases where it is more effective to use a different folder structure in LANconfig than that required for group

configuration. Devices in location-specific folders can indeed be set up with the same group configurations. To avoid

having to create the same partial configuration for every folder, links to a common partial configuration file can be

created in multiple folders.

(1 To use an existing partial configuration file for a group configuration, click on the appropriate folder with the
right-hand mouse key and select Add group configuration... from the context menu.

(@ In the subsequent dialog, select the existing partial configuration file to create a link to this file in the folder.

Please note that changes to the partial configuration file will lead to changes in that group configuration in
@ various folders.

1.5.2  Update device configurations

By selecting or updating a folder, LANconfig checks the configuration of the devices in this folder for agreement with
the settings in the active group configuration. In case of discrepancy from the group configuration, the device status
informs that 'Group update recommended'.

To load the group configuration into the WLAN device, drag the group configuration entry onto the appropriate
device entry. After successfully transferring the parameters, the device status will change to '0K".
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% LANconfig - \WLAN =101x]
Fle Edt Device ¥ew Toos Help
sol 0| Bl Bl Sl galed] Felceldaldl Slalm] ol e
|2 Laniconfig Name: Description [ Address [ Device Status [ Progress
a8 WLaN ELANCOM Group Wireless 5,00 © Group Configuration
GALANCOM DSL/T-1611 Office 192.468.2.400 Ok
G VPN_NHAMEL 192.168.2.100 Ok

It is also possible to use the partial configuration for a device as a group configuration. Simply drag the
device entry onto the group configuration entry.

1.5.3  Update group configurations

Apart from manually changing the parameters in a group configuration, the current configuration of a device can be
used as the basis for a group configuration. One device is thus declared as "Master" for all other devices in the same
file.

To take over the values from a current device configuration for a group configuration, simply drag the entry for this
device onto the desired group configuration. All of the parameters defined in the group configuration are then over-
written by the values in the device configuration.

The next time that LANconfig checks the devices, it will find that the configurations in the other devices no longer
agrees with the new group configuration; this will be displayed by the device status.

% LANconfig - \Central Site ] 3]
Fle Edt Device Wiew Toos Help
ol x| mlBlE| sl il sales] e wlw] wlm]m] 2w e

LaNconfig
454 Central Site Epal

Description Address | Device Status | Progress |
M Group Config. .

192.168.2.102 ok

1.5.4  Using multiple group configurations

Multiple group configurations can be created within a single folder. Only one of these group configurations may be
active at a time since the device status only relates to one group configuration. Active group configurations are indi-
cated by a blue tick, inactive group configurations are indicated by a red cross. To activate a group configuration,
click on the entry with the right-hand mouse key and select Active from the context menu. All other group configu-
rations are then deactivated automatically.

@ Different group configurations in one folder may not be linked to the same partial configuration file.

=t
% LANconfig - \WLAN

File Edit Device Yisw Tools Help

”—'—,—,_J@me%%@m%ﬁ FEEE e E R e R

IM Group Wireless 5,00 Gre:l:: C:Jn:ﬁguratmn = | E iz Description Address Device Status

M Group Wireless 5.00 Group Configuration 2 LA SHLANCOM Group Wireless 5,00 Group Configuration

M DSL{I-1611 Office 192.168.2.101 ok = Edit Enter figuration

IHAMEL 19z 168,100 Ok BILANCOM 1921682100 Ok
EIVPN_RHE 192.168.2.100 Ok

Updste Recommended

Delate

Properties Alb+Enter

1.5.5 Transferring device configurations to similar models

When changing to a different device type, it is often necessary to adopt aspects of the configuration of the previous
model. To do this, LANconfig offers the ability to load the configuration file (*.Icf) of a source device onto a similar
destination device. All of the configuration parameters available on both source and destination devices assume the
previously used values where possible:

B If the destination device has the appropriate parameter, and the value lies within the possible range, the value
of the source device is taken.

B If the value of a parameter available on the destination device is not supported, the default value is used.
Example:

1-17
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The source device has four Ethernet interfaces.
The destination device only has two Ethernet interfaces.
The interface for an IP network is set to LAN-4 on the source device.

This value is not supported on the destination device. The value is therefore set to default value "LAN-1" on
loading the configuration file.

W All destination-device parameters that were not available on the source device retain their respective values.

oo oo

Proceed as follows to transfer the configuration onto a new device:

(1 The firmware levels of the source and destination devices should be matched as closely as possible. Every new
LCOS firmware version features new parameters. Using the same firmware on the two devices allows the greatest
possible matching of available parameters.

(2 Save the configuration of the source device with LANconfig , e.g. via Device » Configuration Management
> Save as File.

(3 Disconnect the source device from the network to avoid address conflicts.

@ Load the configuration onto the destination device using Device » Configuration Management » Restore
from File. Messages on the conversion of the configuration are displayed in an information window.

new devices to be operated in parallel with the source device in the same network. Because key communi-
cation settings, such as the IP address of the device and DHCP settings, are transferred to the destination
device, parallel operation of the source and destination devices in one network may result in conflicts. The
configuration of several devices in one network is facilitated by group configuration and configuration via
scripts.

@ Please note that this function is intended primarily for replacement devices and not for the configuration of

1.6 LANmonitor—know what's going on

The LANmonitor includes a monitoring tool with which you can view the most important information on the status
of your routers on your monitor at any time under Windows operating systems—of all of the LANCOM routers in the
network.

Many of the internal messages generated by the devices are converted to plain text, thereby helping you to troubles-
hoot.

Explanations about the LANmonitor messages and helpful tips can be found in the appendix under 'Error
@ messages in LANmonitor’ — page 700.

You can also use LANmonitor to monitor the traffic on the router's various interfaces to collect important information
on the settings you can use to optimize data traffic.

In addition to the device statistics that can also be read out during a Telnet or terminal session or using WEBconfig,
a variety of other useful functions are also available in LANmonitor, such as the enabling of an additional charge
limit.

With LANmonitor you can only monitor those devices that you can access via IP (local or remote). With this
program you cannot access a router via the serial interface.

1.6.1  Extended display options

Under View » Show Details you can activate and deactivate the following display options:
W Error messages

B Diagnostic messages

B System information

Many important details on the status of the LANCOM are not displayed until the display of the system infor-
mation is activated. These include, for example, the ports and the charge management. Therefore, we
recommend that interested users activate the display of the system information.

1.6.2  Enquiry of the CPU and Memory utilization over SNMP
The load on CPU and memory in the LANCOM can be queried with SNMP or displayed in LANmonitor.
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'3: LANmonitor

File Device Yiew Tools Help
|z &|els|||€ B X
L

F-8 WAN connections: 1

ﬁ Wireless LAN

[]---é YPM connections: 1

[—:IQ@ Firewall: 31.3.2005 16:00:16 DEMNY_ALL - Packet rejected

----- ° 31,3.2005 16:00:16: DENY_ALL - UDP packet from 192,1658.2,113:1901 to 239,255,255,250:1900 -
----- ° 31,3.2005 15:55:16: DENY_ALL - UDP packet from 192,165.2,113:1901 to 239,255,255,250:1900 -
----- ° 31,3.2005 15:50:16: DENY_ALL - UDP packet from 192,165.2,113:1901 to 239,255,255,250:1900 -
----- ° 31,3.2005 15:45:16: DENY_ALL - UDP packet from 192,1658.2,113:1901 to 239,255,255,250:1900 -
----- ° 31,3.2005 15:40:16: DENY_ALL - UDP packet from 192,1658.2,113:1901 to 239,255,255,250:1900 -
I'_—'lo Syskem information

EIQ} Device: LAMCOM 1811 Wireless DIL

----- o Firrmware version: 4.12.0029

----- ¥ Serial number: 015300600046

----- € MAC address: 00a0570fb3bF

----- o Date and time: 31.03.2005 17:26:17

----- ¥ System up time: One day and one hour

----- o CPU type: Inkel iXP425 Stepping BO

----- € CPU clock: 533 MHz

----- € CPUload: 0%
----- o Takal memary: %384 KBytes

----- o Free memory: 5469 KBytes

]‘ WLAN card: Atheros ARSZ1Z2/ARS111/ARZ111
) WAN interfaces: DSL, ISDM, V.24

- Total charge: 0 units

£-g@ Tokal online kime

1 |

=10l x|

LANCOM

Systens

Packe
Packe
Packe
Packe
Packe

[l

1.6.3  Monitor Internet connection

To demonstrate the functions of LANmonitor we will first show you the types of information LANmonitor provides
about connections being established to your Internet provider.

(D To start LANmonitor, go to Start » Programme » LANCOM P> LANmonitor. Use File » Add Device to set

®

@

up a new device and in the following window, enter the IP address of the router that you would like to monitor.
If the configuration of the device is protected by password, enter the password too.

Alternatively, you can select the device via the LANconfig and monitor it using Device » Monitor Device.

LANmonitor automatically creates a new entry in the device list and initially displays the status of the transfer
channels. Start your Web browser and enter any web page you like. LANmonitor now shows a connection being
established on one channel and the name of the remote site being called. As soon as the connection is estab-
lished, a plus sign against the communication channel entry indicates that further information on this channel
is available. Click on the plus sign or double-click the appropriate entry to open a tree structure in which you can
view various information

'3: LANmonitor

=1k
Device Wiew | Tools Help

eam LC_YPN_M_ YPN Connections
e LC_WPN_M_

Accounting Information

Firewall Event Log

Wiew Saved Accounting Information ...
+ REdL

2/6/2003 23:45:49 intruder detection - Packet dropped

: intruder detection - Pa of prokocol S0 from 10,958,100,11:0 ko 10,1,1,10:0 - Packet dropped

: é WPMN connections
o Syskem information
oo LC1621 Internet

feam 1621AnnexE

o LC_RAS

In this example, you can determine from the PPP protocol information the IP address assigned to your router by
the provider for the duration of the connection and the addresses transmitted for the DNS and NBNS server.

Under the general information you can watch the transmission rates at which data is currently being exchanged
with the Internet.

To break the connection manually, click on the active channel with the right mouse button. You may be required
to enter a configuration password.

If you would like a log of the LANmonitor output in file form, select Device » Device Activities Logging and
go to the 'Logging' tab. Open the dialog for the settings for the activity protocol, click on Tools » Options.
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options 2| ]
Fecaord | Logging |

— Filter

T, W Log'waN connections
e
v

Log 'WLAN connections

V¥ Log VPN connections
[V Log LANCAFI connections
[V Log a/b-ports connections
[V Log actions of Firewall

— Buffer:
™ Load Activity Log file at the start of record

Buffer size: |100 ~ Lines

™ Stop record, if buffersize is reached

()8 Cancel |
e

On the 'Protocol' tab you can define whether the following activities should be protocolled:

WAN connections
WLAN connections
VPN connections
LANCAPI connections
a/b port connections
O Firewall actions

I i B

You can also specify whether LANmonitor should create a log file daily, monthly, or on an ongoing basis.

1.6.4  Display functions in LANmonitor

LANmonitor supports the administration of the LANCOM applications by offering a range of functions that simplify
the surveillance of devices at widely dispersed locations. The overview of devices monitored by LANmonitor already
shows the most important information about the status of the devices:

8} LANmonitor

Fle Device View Tools Help

-l

e LC1621. Internet
=1 DSL Line 1: Not ready
4 Error (ISDH): Connection establishment Failed (D-channe layer 2) [0x0082]
=3 ISDN Line 1: Ready
=3 ISDN Line 2: Ready
=3 DSLol Line: Ready
=R ]Fire: 004 jon - ppeC
@ 5.1.2004 14:34:43: DoS protection - UDP packet from 127.0.0.1:58 to 255.255,255.255:67 - Packet dropped
@ 4.12.2003 ::59:28 intruder detection - Packet of protocol O from 10.1.140.154:0 to 10.1,80.125:0 - Packet rejected
@ 3.12.2003 14:25:44: intruder detection - Packet of protocol 0 from 10.1,80.180:0 to 10.1,80.125:0 - Packet rejected
£y VPN cannections
=¥ System information
(=) 43 Device: LANCOM 1621 ADSL{ISDN
€ Firmware version: 3.20.0029

€ Serial number: 855050000017
€9 MAC address: 00a0570b13F
€9 Location: E.212
€ administrator: GReichel
€ Date and time: 1/29/2004 12:24:26 PM
€ System up time: 62 days and 0 hours
£ WAN interfaces: ADSL, 1SDN, DSLol
E-¥ ADSL modem: Handshaking
" Line type: ADSL over ISDN (Annex B}
W Line code: U74.4.3
" Line mode: Multimode
" Upstream rate: 0 kBit/s
%~ Downstream rate: O kBitjs
% Signal-to-Moise ratio: 0.0 d&
EF¥ ISDN; DSS1 (Eura-1SDN)
W~ 50 bus active: Yes
% TEI assigned: Yes
W Layer 2 active: No
- DSL over LAN
T Link state: Up

= B8 Tatal charge: 0 units
£ Router (ISDN): 0 units
B LANCAPL: 0 units
£ Time sync.: 0 units
=& Total anine time

Router (ADSL): 0 minutes

Router (ISDN) (outgaing): 0 minutes

i e (TEPRY fincerminmb: ) mio kac

|

Bl

The information that can be taken from the overview includes, among others, details about active WAN connections,
the five most recent firewall messages, the current VPN connections and system information about charges and

online times.
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Right-clicking with the mouse on a device in LANmonitor opens up a context menu with further information:
B VPN connections
The list of VPN connections is a log of the 100 most recent VPN connections. The detailed recorded information

includes
& LC_¥PN_M_LCSTEST - ¥PN Connections =1ol x|
Connections  View
Mlamme [ state [ Last Errar [ short Hold [ conmection [ Gateway [ Encryption Algorithm | Hmac Algorithm [ Hash Algarithrn |
{ZWPN_CBUERSCH  Connected 0 seconds INTERNET 80.142.179.234 BLOWFISH {128 bit) tnone) (0 bit) HMAC_5HA (160 bit)
CGYRN_CSCHALLE  Connected 0 seconds INTERNET 80.146.104.30 AES (128 bit) fnone) (0 bit) HMAC_MDS (128 bit)
SQWPN_C_BUHMAN  Notconnected  ISDWorDSLer.. O seconds WPN_C_BUHMAN  10.98.100.87 3DES (192 bit) tnone) (0 bit) HMAC_MDS {128 bit)
< YPN_DEICH Connected 0 seconds INTERNET 80.142.147.155 BLOWFISH (128 bit) fnone) (0 bit) HMAC_SHA (160 bit)
S WPN_DKRAU Mok connected  Dynamic VPR -... O seconds INTERNET 0.0.0.0 tnone) (0 bit) tnone) (0 bit) tnone) (0 bit)
< ¥PN_ETRABER Connected 0 seconds INTERNET 212.202.73.28 BLOWFISH (128 bit) SHA (160 bit) HMAC_SHA (160 bit)
{mWPN_FIANSSEM  Connected 0 seconds INTERNET 213.23.254.17 BLOWFISH {128 bit) SHA (160 bit) HMAC_SHA (160 bit)
<gYRN_FTHEINEN  Connected 0 seconds INTERNET 80.146.80.3 BLOWFISH (128 bit) fnone) (0 bit) HMAC_SHA (160 bit)
C&WPN_HBATTI Connected 0 seconds INTERNET 80.146.95.224 BLOWFISH {128 bit) tnone) (0 bit) HMAC_SHA (160 bit)
< YRN_MBAGSIK Connected 0 seconds INTERNET 82.52.224.144 AES (128 bit) fnone) (0 bit) HMAC_MDS (128 bit)
<z WPN_MERIZ Connected 0 seconds INTERNET 213.54.108.209 AES (128 bit) tnone) (0 bit) HMAC_MDS {128 bit)
< YRN_MPLUM Connected 0 seconds INTERNET 80.146.86.178 BLOWFISH (128 bit) fnone) (0 bit) HMAC_SHA (160 bit)
CHWPN_OSCHILPE  Connected 0 seconds INTERNET 82.72.51.240 AES (128 bit) tnone) (0 bit) HMAC_MDS {128 bit)
<GURN_PCPRO Connected 0 seconds INTERNET 62.226.217.119 AES (128 bit) fnone) (0 bit) HMAC_MDS (128 bit)
<gWPN_Qs_TEST Connected 0 seconds INTERNET 80.146.87.133 AES (128 bit) tnone) (0 bit) HMAC_MDS {128 bit)
s, N - . - - - N PR -

O Name of the remote device
Current status

Last error message

IP address of the gateway
Encryption information

B Accounting information

The accounting information is a protocol of the connections from each station in the LAN to remote sites in the
WAN. The detailed information recorded includes

oo oo

=10l

[ Remate Site [ Tvpe [ connections | Received | Transmitted | Tatal Online Time | &
VPH_QS_TEST VPR connection [ 0KE OKE 1732 days and 21 hours
VRH_WTTW VPH connection o 833 KB F40KB 18 days and & hours
VPH_CSCHALLE VPR connection 0 12,899KE  10,552KE 18 days and & hours
buersch-gs VPH_CBUERSCH VPR connection 0 1,007,185 KB oke 17 days and 22 hours
= chuersch-gs VPH_CBUERSCH PR connection 0 1KE 1,129 MB 17 days and 22 hours
_wpn_m_sthout VEH_WOHH VPH connection o 3904KB 113,534 KB 17 days and 21 hours
=1 _vpn_m_ethout VPH_W TN YPH connection 0 SIEKE  58,035KE 17 days and 14 hours
lev-prodtest VPH_HBATTI VPH connection o OKE  434,448KB 16 days and 18 hours
10.1.80,173 YPH_HBATTI YPH connection 0 457,390KE 0kE 16 days and 18 hours
0.1.80,172 VPH_FTHETNEM VPR conmection o OKE  11,855KB 15 days and 5 hours
0.1.80,172 VPH_FTHEINEM VPR connection 0 3,938 KB 0kE 15 days and 5 hours
s-voip VPH_ETRABER  VPH conmection 0 17,761KB 12,425k 14 days and & hours
_vpn_m_gthout VPH_TNIO YPH connection 0 189 KB 366 KB 13 days and 14 hours
s-data VPH_MPLUM VPH connection o 3,7BKE 40,225KE 11 days and 22 hours
= les-voip YPH_MPLUM YPH connection 0 40,205KE  3,12LKE 11 days and 10 hours
0.1.80,172 VPH_TNIO VPH connection o 112¥8 oke 11 days and 10 hours
=1 _vpn_m_ethout VPH_MBAGSIK VPR connection 0 SESIKE  ZA0ATKE 11 days and % hours
SRYPN_HBATTT INTERKET Disl-up (D5L) 0 eB,508KE 67,582k 10 days and 20 hours
= s mail VPH_TNIO YPH connection 0 52,152KE  266,545KE 10 days and 18 hours
Janprint VPH_ETRABER  VPH conmection 0 443,863KB 1,656 MB 10 days and 17 hours

= dualp3 YPH_MPLUM YPH connection 0 393,063KE  535,872KE 9days and 11 hours =)

O Name or IP address of the station

[0 Remote station used to establish the connection

0 Type of connection, e.g. DSL or VPN

0 Number of connections

0 Data volume sent and received

0 Online time

B Activity log
The activity log is a detailed list of the connections via WAN, WLAN, VPN, LANCAPI and a/b port, and a list of
firewall activities. The detailed information recorded includes

o=l
Fie View Tooks
Date and tne [ source [ Message [=]
1AM VPN o connection to YPN_C_BUHMAN - Last Error 1SDM or DSL error on interfac. .

PR Connected to YPH_DEICH (via INTERKET)

PR Ko cennection to YPN_PKRAL - Last Errar: Dynamic PN - n ISDM call numb. .

PR Connected to YPH_ETRAGER (via INTERNET)

PR Comnected to VPH_FIANSSEN (via INTERNET)

PR Comnected to VPH_FTHEINEN (via INTERNET)

PR Comnected to YPH_HBATTI (via INTERNET)

wan DSL Line - INTERHET , Connect

PR Connected to YPH_MBAGSIK (via INTERNET)

PR Connected to VPH_MBRIX (via INTERNET)

PR Connected to YPH_MPLUM (via INTERNET}

PR Comnected to YPH_OSCHILPE (via INTERNET)

PR Connected to YPH_PCPRO (via INTERNET}

PR Comnected to YPH_GS_TEST (via INTERNET)

PR Connected to YPH_WOHH (via INTERMET}

PR Comnected to VPH_WTIW (via INTERMET} =

0 Date and time
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O Source
O Message
m Firewall actions log
The firewall actions log lists the last 100 actions taken by the firewall. The detailed information recorded includes

o
EverttLog  View
Idx, | System time [ Source address | Dest. address | Prot__ | Source ... | Dest. p... | Fikerrule | Limit [ action -
1 24004 121241 10,1111 224009 17(U... 520(r0.. 520(ro.. intruderde... Immedistely  Packst dropped; SYSLOG sent
Sz 247004121140 10,1111 255.255.255.255 17(U... 67(bo.. 68(bo.. intruderde. Immediately  Packet dropped: SVSLOG sent
3 24200412:0645 10,1111 224009 17(U..  520(ro.. 520(ro.. intruderde.. Immedistely  Packst dropped; SYSLOG sent
4 247004120549 10,1111 255.255.255.255 17(U... 67(bo.. 68(bo.. intruderde. Immediately  Packet dropped: SVSLOG sent
5 240e12:0232 10,1111 224009 17(U..  520(ro.. 520(ro.. intruderde.. Immedistely  Packst dropped; SYSLOG sent
D6 247004120050 10,1111 255.255.255.255 17(U... 67(bo.. 68(bo.. intruderde. Immediately  Packet droppedi SVSLOGsent  —
7 242004 12:0004 10,1111 224009 17(U..  520(ro.. 520(ro.. intruderde.. Immedistely  Packst dropped; SYSLOG sent

S5 24j2004
o z4jz004
S0 24j2004
11 242004 11
12 2/4/2004 11

03 100011 10.1.255.255 1700, 137(n.. 137(n.. intruderde.. Immediately  Packet dropped; SYSLOG sent
08 10.11.11 2240.0.9 17(U.. 520(r0.. 520(wc... intruderds... Immediastely  Packet dropped; SYSLOG sent
07 100111 255.255.255.255  17(U.. 67(bo... 68(bo.. intruderde.. Immediately  Packet dropped; SYSLOG sent
05 10111 2240.0.9 17(U.. 520(r0.. 520(wc... intruderds... Immediastely  Packet dropped; SYSLOG sent
04 10111 255.255.255.255  17(U.. 67(bo... 68(bo.. intruderde.. Immediately  Packet dropped; SYSLOG sent

13 z4j2004 10.1.1.11 2240.0.9 17(U.. 520(0... intruder de... Immedistely  Packet dropped; SVSLOG sent
14 2/4/2004 11:43: 10.1.1.11 10.1.255.255 1700, 13700, ... intruder de... Immediately  Packet dropped; SVSLOG sent
15 242004 11:42:13 101111 2240.0.9 17(U.. 520(r0.. 520(ro... intruderds... Immediately  Packet dropped; SYSLOG sent

Time

Source and destination address

Protocol with source and destination port
Activated filter rule and exceeded limit
Action carried out

O o0Oo0ooaod

1.6.5 Connection diagnosis with LANmonitor

LANmonitor can be used to check the connection quality between stations in the LAN, WAN or WLAN. LANmonitor
sends pings from the computer on which it is installed to the remote site at regular intervals. The responses it receives
are the basis for a compiled report.

To enter the parameters and display the results, a dedicated dialog has been implemented in LANmonitor.

iEix
—Settings Statistic:
Host name or IP address: I www.lancom.de Description | Total run time | Period |
Test run time: 00:00:15
Ping interval (ms): I 1000
Transmitted: 20 20
Ping timeout (ms): I 1000 Last ping (ms): 50 50
Data (bytes): 100 Received until timeout: 20 20
Minimum {ms): 43 43
Maximum (ms): 56 56
Execution: Average (ms): 45 45
Standard deviation {ms): 1 1
% Permanent
Received after timeout: 0 0
" Duration{hh:mm): I : I Late (%): 0,0 0,0
Minimum {ms): 1] 1]
" Number of pings to send: I Maximum (ms): 1] 1]
Average (ms): 1] 1]
Period evaluation: Lost: i} i}
Lost {¥&): 0,0 0,0
MNumber of packets for evaluation: I 100
Last error:
Start | Stop I Cancel |

LANmonitor: Tools » Ping... or via the context menu

Configuring Ping execution
B Host name or IP address

The remote station which is to be queried by Ping is entered here. The following information can be entered for
all of the different network devices (servers, clients, routers, printers, etc.) which can be reached via LAN, WAN
or WLAN.

If a device is selected when the Ping dialog is opened with Device P> Ping... or via the context menu in
@ LANmonitor, then the IP address of this device is assumed to be the remote site.

H Ping interval
The time interval between two consecutive pings in [ms].
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The interval between two pings cannot be less than the packet transmission time, i.e. before sending a ping,
@ the previous ping must have been answered or the ping timeout must have expired.

B Ping timeout

The time waited for the response to a ping to arrive [ms]. If this time expires and no response was received then
the ping is assumed to be lost.

B Data
The size of a ping packet [bytes]. A "ping" is an ICMP packet which is generally transmitted without any content,
i.e.itis just a header. To increase the load of the packets used for testing a connection, a payload can be created

artificially. The overall packet size then consists of an IP header (20 bytes), an ICMP header (8 bytes) and the
payload.

@ The packets will be fragmented if the payload of the ICMP packets exceeds the maximum IP packet size.

B Execution
Repeat mode for the ping command.

Evaluation

The right-hand portion of the Ping dialog displays the results of the ping test. The first column shows the sum values
over the entire test; the second column shows only the values collected over the evaluation period, i.e. the sum of
the most recent packets. Unanswered pings are not included in the evaluation.

@ The period evaluation considers only the pings sent during the defined period.

The following information is displayed for evaluation:
H Test run time
0O The total run time [hr./ min./ sec.]
B Transmitted
O Total number of pings sent
O Run time of the last ping [ms]
B Received until timeout
The number of pings answered in the timeout period
Minimum runtime
Maximum runtime
Average
Standard deviation from the mean run time
B Received after timeout
The number of pings answered after the timeout period
Late packets as a proportion of the total number
Minimum runtime
Maximum runtime
Average
B Lost
[0 The number of lost packets
0 Lost packets as a proportion of the total number

O 0Oo0Oooaod

O 0O0ooao

1.7 Visualization of larger WLANs with WLANmonitor

With LANCOM WLANmonitor you can centrally monitor the status of a wireless network( WLAN). It presents infor-
mation about the entire network in general and detailed information about individual access points and logged-in
clients. LANCOM WLANmonitor can also collect access points into groups. These groups may consist of access points
gathered in buildings, departments, or at particular locations. In particular with large WLAN infrastructures, this
helps to keep an overview of the entire network.
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1.7.1  Start the LANCOM WLANmonitor

WLANmonitor is a component of LANmonitor. Start WLANmonitor from LANmonitor using the menu item Tools
»WLANmonitor, by using the corresponding button in the LANmonitor button bar or directly with Start »
Programme » LANCOM P> WLANmonitor.

-loix
File Device Yiew Tools Help
<ol ol falsa| o] o|B|R| R B el X FAME2

T_MHAMEL WLAMmonitar

AN connections: 1

WPMN connections: 1

+ Wireless LAN

E@ Firewall: 6/17/2005 9:49:35 intruder detection - Packet dropped

Alternatively, WLANmonitor can be started from the console with the command

[installation path]lanmon -wlan

1.7.2  Search for access points

After starting WLANmonitor, commence a search for available access points via the menu item File » Find access
points. The access points found are listed in the middle column. Also shown here is the main information for each
access point such as the name, number of registered clients, the frequency band and channels being used.

B Name of the access point

Number of the connected clients

Used frequency band

Used channel

IP address of the access point

The right-hand column (client list) lists the clients that are logged in to the selected access point. The following infor-
mation is shown for each client:

B Connection quality as a bar chart

B |dentification: The name of the logged-in client in as far as this is entered into the access list or a RADIUS server.
LANconfig: WLAN Security » Stations » Stations

Telnet: Setup/WLAN/Access- List

WEBconfig: LCOS menu tree » Setup » WLAN » Access-List

Signal: Connection signal strength

Access point: Name of the access point that the client is logged on to

SSID: Identifier for the WLAN network

Encryption: Type of encryption used for the wireless connection

WPA version (WPA-1 or WPA-2)

MAC address: Hardware address of the WLAN client

TX rate: Transmission data rate

RX rate: Reception data rate

Last event, e.g. 'Authentification successful’, 'RADIUS successful'

IP addresss of the WLAN clients

=Dl x|

Fle Access Pont View Toos T

w0 |

LANCOM
i

Jrops

| mecess poes |cheres

=] | st | Chores [and [ cha.. | Poaddess | Idsrpficanon 5 AccessPont | SSI0N | Kyl WA | Mac-address Doiare | Rndse | LastEvens B-Adbess
| oifen R 4. 10 19216020, all heiaenel bl % 1 AL 1 DOIESZAY  GAMBR)e SAMIR) Key-Dohange.. 19L1G0LT9
S R | LA 0 10,1483

1.7.3  Add access points

If an access point was not recognized automatically, it can be added to the list manually with the menu item File »
Add access point. In the following window, enter the IP address or the name of the access point, the administrator
name, and the corresponding password.
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—Address
() Please enter the IP address or name of the

Q’\ device to be monitored here,
13 [p.0.0.0 |

r—Authentication

ey If a password is needed to access the
Q’? device, enter the password here,

Administrator: I
Password: I

Mote: The administrator may only be specified if
an administrator account has been configured in
the device

1.7.4  Organize access points

The LANCOM WLANmonitor lets you organize all of the available access points in a manner that is independent of
their physical location. This helps to maintain an overview of the network and is particularly useful when localizing
problems. Further, WLAN information can be called up according to the groups. You can group your access points
according to their departments, locations or applications (e.g. public hotspot), for example.

The groups are shown in the left column in WLANmonitor. Starting from the top group 'WLANmonitor', you can use
the menu item File » Add group to create new sub-groups and so build up a structure. Access points found during
a search are assigned to the currently selected group in the group tree. Access points that have been recognized
already can be moved to the another group with drag and drop.

B =10] x|
File AccessPoint View Tooks 7
= LANCOM

O | gy i
Groups Access Points Clierts
) [ Hame [ clients [Band [ channel [ [ Tdentification [ signal [ AccessPaint | SSIDn | Key-Type | mac-address | Té-Rate | Rx-Rate [ |
=3 Location Aachen & WPH_WHAMEL 1 24, 10 all 47 WPN_NHAMEL 1 -~ 00100625253 18 MBitjs 48 MBitjs

{0 Camp

A "

= Location Berlin
{1 Accountancy
w{Z7] Managemnent

= Location Munich
w{_1] Administration

{7 Training

K | g | K1} | |
[ I 4

To aid the allocation of access points and clients, you can mark a device with the mouse. The counterpart(s) will then
be marked in the list as well:

B If an access point is marked in the access point list, all of the clients logged in to this device will also be marked
in the client list.

m If aclientis marked in the client list, the access point that it is registered with will be marked in the access point
list.

1.7.5 Rogue AP and rogue client detection with the WLANmonitor

WLAN devices that make unauthorized attempts at accessing a WLAN by posing as an access point or client are
called rogues.

B Rogue clients are computers equipped with WLAN adapters that are located within the range of a WLAN and
attempt to log on to one of the access points, for example, in order to use the Internet connection or in order to
receive access to secured areas on the network.

B An example of rogue APs are access points that a company's employees connect to the network without the
knowledge or permission of the system administrators, thereby consciously or unconsciously making the network
vulnerable to potential attackers via unsecured WLAN access. Not quite as dangerous, but disruptive all the same
are access points that belong to third-party networks yet are within the range of the local WLAN. If such devices

also use the same SSID and channel as the local AP (default settings), then local clients could attempt to log on
to external networks.

Unidentified access points within the range of the local network frequently pose a possible threat and security gap.
At the very least they are a disturbance, and so they need to be identified to decide whether further measures in
securing the local network need to be introduced. Information about the clients within range of your network is

1-25
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automatically stored to an internal table in the LANCOM Wireless Router. Once activated, background scanning
records neighboring access points and records them to the scan table. WLANmonitor presents this information visu-
ally. The access points and clients found can be categorized in groups such as 'known', ‘unknown' or ‘rogue’.

@ Further information can be found under ‘Background WLAN scanning’ — page 25.

Rogue AP detection

The WLANmonitor sorts all of the access points found into predefined subgroups under 'Rogue AP Detection' while
displaying the following information:

Time of first and last detection

BSSID, the MAC addresse of the AP for this WLAN network

Network name

Type of encryption used

Frequency band used

Radio channel used

Use of 108Mbps mode

@ To use rogue AP detection, background scanning has to be activated in the LANCOM Wireless Router.

The WLANmonitor uses the following groups for sorting the APs that are found:
Bl All APs: List of all scanned WLAN networks grouped as follows

B New APs: New unknown and unconfigured WLAN networks are automatically grouped here (APs displayed in
yellow)

Rogue APs: WLAN networks identified as rogue and in need of urgent observation (APs displayed in red)
Unknown APs: WLAN networks which are to be further analyzed (APs displayed in gray)

Known APs: WLAN networks which are not a threat (APs displayed in gray)

Own APs: New affiliated WLAN networks from access points monitored by WLANmonitor are automatically grou-
ped here (APs displayed in green)

The WLANSs that have been found can be placed into a corresponding group depending on their status. You can set
up your own network groups within the individual groups by using the context menu (right mouse button) (except
for the group 'All APs’).

2 WL ANmonitor

File AccessPoint  Wiew Tools 7

& % % | 6y
IGroups IRogue AP Detection
|11 wLANmonitor {12) | Lask Seen | Identification | Metwork Mame (5., | Band | Cha... | Encry... | 108... | First Seen
- Rogue AP Detection @ 15.08.2006 15:45:43  Clientol Metwork1 2,4GHz 11 Mome Mo 29.06.2006 1
4 @ 15.08.2006 15:45:49  Client02 MetworkD1 Z,4GHz 11 Mone Mo 29,06, 2006 1
L = ClS @ 03.07.2006 16:39:05  Client03 MetworkD1 SGHz 100 AES Mo 013,07, 2006 1
- EDE:'E AP:P @ 03.07.2006 16:39:05  Cliert04 Metwarkn1 SGHz 100 AES Mo 03.07.2006 1
j Kgowiwgps s @) 04.07.2006 18:16:46  Client0l MetworkDz Z,4GHz 11 Mone Mo 013,07, 2006 1
31 Own APs @ 09.08.2006 15:39:52  Client02 MetworkDz Z,4GHz 11 Mone Mo 09,08, 2006 1
-1 Rogue Client Detection W 15.08.2006 15:45:44 Sl 0.0.030  Interface: WLAN-1, Signal: 50 % M° A
1 #ll Clients (2) @ 11.08.2006 03:15:06  Client04 10,110,193;  TnkerFace: WLAN-1, Signal: 10 % Mo 10,08, 2006 1
1 New Clisrts (1) @ 11.08,2006 12:27:58  Client0l 10.1,10,192:  Interface: WLAN-1, S?gnal: 31 % Mo 11.08.2006 1
. 18.08.2006 15:46:03  Client02 10,1,10,18%:  Interface: WLAN-1, Signal: 45 % M 15.08.2006 1
—1 Rogue Clients b e 10,1.10.188:  Inkerface: WLAN-1, Signal: 18 % o
1 Unknown Clients @ 18.08,2006 15:46:03  Clientd3 TG, ToT TIOTTE, Mo 158.08.2006 1
1 Knawn Clients @ 15.08.2006 15:45:20  Client04 Z,4GHz 11 Mone Mo 18,08, 2006 1
1 Own Clients @ 18.08,2006 15:45:20  Clientd1 MetworkOd 24GHz 11 Mone Mo 158.08.2006 1
I:‘i 12 N2 2NNes 154544 ~liambn? Rlakiamel Lnd P dTH= = WWFD Rl 20 NE PNne 1

@ If a parameter is changed on an AP, e.g. the security settings, then it is displayed again as a newly discovered
AP,

Rogue client detection

The WLANmonitor presents all of the clients found into predefined subgroups under ‘Rogue Client Detection' while
displaying the following information:

B Time of first and last detection
B MAC address of the client
m Network name
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@ No configuration of the LANCOM Wireless Router is necessary to make use of rogue client detection.

The WLANmonitor uses the following groups for sorting the clients that are found:

All clients: List of all found clients grouped as follows (clients are colored according to their group)
New clients: New unknown clients are automatically grouped here (clients displayed in yellow)
Rogue clients: Clients identified as rogue and in need of urgent observation (clients displayed in red)
Unknown clients: Clients which are to be further analyzed (clients displayed in gray)

Known clients: Clients which are not a threat (clients displayed in gray)

Own clients: New affiliated clients associated with access points monitored by WLAN monitor are automatically
grouped here (APs displayed in green)

The clients that have been found can be placed into a corresponding group depending on their status. You can set
up your own network groups within the individual groups by using the context menu (right mouse button) (except
for the group 'All clients’).

Activating rogue- AP and rogue-client detection
The functions for rogue-AP and rogue-client detection can be switched on or off in WLANmonitor.

options 2]
General |Alerting|

V¥ Rogue AP Detection activated

V' Rogue Client Detection activated

"Application language

Language: I Englizh - l

:WLANmonitor: Tools » Options » General
B Rogue AP detection activated
Activate this option if WLANmonitor is to display unknown or unconfigured access points.

B Rogue client detection activated
Activate this option if WLANmonitor is to display unknown or unconfigured clients.

Configuring the alert function in the WLANmonitor

The WLANmonitor can inform the administrator automatically via e-mail whenever an unknown or unconfigured
access point is discovered.

options _______ (x|

General  Alerting |

— E-mail Motification

In particular events there may be gent a notification per e-mail.

V¥ Rogue AP detection has found an unknown or
unconfigured Access Point.

Fecipient's e-mail addresses: I admin@company, com

] An e-mail shall be zent automatically without further
= uzer interaction. Hence it is necessary that an e-mail
application iz configured as standard mail application.

The authentication data has to be stored in the account
zettings. Furthermore it has to be azzured that an other
application iz permitted to gend an e-mail using thiz e-mail
application.
M5 Outlook Express and Mozilla Thunderbird are possible
e-mail applications.

To test the E-mail- :
notification it i possible to send Send test e-mail |

a test e-mail

0k | Abbrechen |

WLANmonitor: Tools » Options » Alerts
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Not for cen-
trallymanaged
LANCOM
Wireless
Routers or
LANCOM
Access Points

B E-mail messaging
Activate this option if you would like the WLANmonitor to report unknown or unconfigured access points via e-
mail.

B Recipient e-mail addresses

Enter the e-mail address(es) of the administrators here that should be informed in the event of rogue AP detec-
tion. Multiple e-mail addresses should be separated by commas.

In order to send e-mail alerts, the computer on which WLANmonitor is running requires a standard e-mail
client (MS Outlook Express or Mozilla Thunderbird) that allows automatic mail transmission to be configured
and running.

B Send a test e-mail

Some mail clients require a confirmation from the user before sending via third-party applications. Test the alarm
function with this button.

1.8  Configuration with WEBconfig

New with LCOS 7.6:
B New WEBconfig with search function, comprehensive device status, on-line help, etc.

Device settings can be configured from any Web browser. WEBconfig configuration software is an integral compo-
nent of the LANCOM. A Web browser is all that is required to access WEBconfig. WEBconfig offers similar Setup
Wizards to LANconfig and hence provides the perfect conditions for easy configuration of the LANCOM — although,
unlike LANconfig, it runs under any operating system with a Web browser.

Secure with HTTPS
WEBconfig offers an encrypted transmission of the configuration data for secure (remote) management via HTTPS.

https://<IP address or device name>

For maximum security, please ensure to have installed the latest version of your Internet browser. For Win-
dows 2000, LANCOM Systems recommends to use the “High Encryption Pack” or at least Internet Explorer
5.5 with Service Pack 2 or above.

Access with WEBconfig

To carry out a configuration with WEBconfig, you need to know how to contact the device. Device behavior and
accessibility for configuration via a Web browser depend on whether the DHCP server and DNS server are active in
the LAN already, and whether these two server processes share the assignment in the LAN of IP addresses to sym-
bolic names.

Following power-on, unconfigured LANCOM devices first check whether a DHCP server is already active in the LAN.
Depending on the situation, the device can either enable its own DHCP server or enable DHCP client mode. In the
second operating mode, the device can retrieve an IP address for itself from a DHCP server in the LAN.

If a LANCOM Wireless Router or LANCOM Access Point is centrally managed from a LANCOM WLAN
Controller, the DHCP mode is switched from auto-mode to client mode upon provision of the WLAN confi-
guration.

Network without a DHCP server

In a network without a DHCP server, unconfigured LANCOM devices enable their own DHCP server service when
switched on and assign IP addresses, information on gateways, etc. to other computers in the LAN (provided they
are set to automatic retrieval of IP addresses —auto DHCP). In this constellation, the device can be accessed by every
computer with the auto DHCP function enabled with a Web browser under IP address 172.23.56.254.

With the factory settings and an activated DHCP server, the device forwards all incoming DNS requests to
the internal Web server. This means that a connection can easily be made to set set up an unconfigured
LANCOM by entering any name into a Web browser.
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¥J LANCOM L-54ag Wireless - Login - Mozilla Firefox o =]

Datei  Bearbeiten  Ansicht  Chronik  Lesezeichen  Extras  Hilfe

L c .m. (et | |http:,|’,|’anyname 2> - |'|Google ).'

LANCOM

Systems

v et o nNecting Yy our business

LANCOM

Password |
Ok

Caution! Your are using an
unen onnection. The
rdl will be transmitted as plain

I

Encrypted connection.

[ Fartin [~ i

If the configuration computer does not retrieve its IP address from the LANCOM DHCP server, it determines the cur-
rent IP address of the computer (with Start » Run » cmd and command ipconfig at the prompt under Windows
2000 or Windows XP, with Start » Run » cmd and command winipcfg at the prompt under Windows Me or Win-
dows 9x or with command ifconfig in the console under Linux). In this case, the LANCOM can be accessed with

un

address x.x.x.254 (the “x"s stand for the first three blocks in the IP address of the configuration computer).

Network with DHCP server

If a DHCP server for the assignment of IP addresses is active in the LAN, an unconfigured LANCOM device disables
its own DHCP server, switches to DHCP client mode and retrieves an IP address from the DHCP server in the LAN.
However, this IP address is initially unknown and accessing the device depends on the name resolution:

B If the LAN also has a DNS server for name resolution and this communicates the IP address/name assignment to
the DHCP server, the device can be reached under name "-<MAC address>", e.g. “-00a057xxxxxx".

File Edit Miew Favorites Tools Help |-
GBack + = - ) at | Qhsearch [GelFavorites  GMedia &4 | N S
Address | i /-00205700094A =] Pco |unks

-

@ The MAC address on a sticker on the base of the device.

B If there is no DNS server in the LAN, or if it is not coupled to the DHCP server, the device cannot be reached via
the name. In this case the following options remain:

O Use LANconfig's “Find Device” function, or perform WEBconfig's “Device Search” from another yet acces-
sible LANCOM.

0 Use suitable tools to find out the IP address assigned to the LANCOM by DHCP and access the device directly
using this IP address.

00 Use the serial configuration interface to connect a computer running a terminal program to the device.

Login
When prompted for user name and password when accessing the device, enter your personal data in the appropriate
fields. Observe the use of upper and lower case.

If you used the general configuration access, only enter the corresponding password. The user name field remains
blank in this case.
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As an alternative, the login dialog provides a link for an encrypted connection over HTTPS. Always use the
@ HTTPS connection for increased security whenever possible.

LANCOM

Systems

L..ctefnecting your business

MyLANCOM
Login

Password =

Caution! Your are using an
unencrypted connection. The

I

password will be transmitted as plain
text

Enerypted connection.

Setup Wizards

The setup Wizards allow quick and easy configuration of the most common device settings. Select the Wizard and
enter the appropriate data on the following screens.

A Setup Wizaras

@ system information Setup Wizards L A N E D M
7 Contiguration Systems.
P LCOS Menu Tree [& Logout

[ File management
7 Extras

[FF HTTP-Session
B Logout * GhBasic Settings.

() Check Security Settings

« @ Set up Interet connection

* @ Selection of Intemet Povicer

» JwSetup a RAS Account

* = Connect Two Local Area Networks
* . Configure WLAN interface

* ¥ Configure dynamic DNE

* v* Create Public Spot Account

Please choose the desired wizard:

@ The settings are not stored in the device until inputs are confirmed on the last screen of the Wizard.
S

ystem information

Under the "System Data" tab on the system information screen displays general information on the device including
its location, the firmware version, the serial number, etc.

A Setup Wizards N R
@ System information System information L A N E D M
‘? Configuration Systems
LH%OSME””’QQ [ Logout C..comaecting gout busines
Ha Status
A Setup System data Device status Byslog
WP Firmware
[ Other Name:
g EIT management Location: |A‘a|:hem Brand
xtras
HTTP-Session Administrator: |
G Logout Comments: |
Device type: |IANCOM1?22VD\P(AMHEX B)
Hardware release: A
Firmware version: |7.:BU.EIUBZ #06.11.2008
Serial number: 0000159300010

The “Device status” tab contains comprehensive information on the current operating state of the device. This inclu-
des, for example, a visual representation of the interfaces with information on the networks active on them. Appro-
priate links can be used to call up further relevant statistics (such as DHCP table). For significant configuration
deficiencies (such as invalid time setting), a direct link to the appropriate configuration parameters is provided.
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A Setup Wizards

@ System information System information L A N c D M
? Configuration Systems
7 LCOS Menu Tree [ Logout
[ File management
# Extias Device status ‘Byslog
[E5 HTTP-Session =
B Logout Interface/Port State/Mode Information
CPU-Load Current 5.56%
Total 12.5 MBytes
M
L Free: 3.3 MBytes
Num-Stations 1
Noise-Level: -85dBm
WLAN-1 Sremne: = Modem-Load 1
Operation-Mode: Access-Paint _
Transmit-Power: 15dBm
Throughput: 4.5KB
Point-to-Point cannsctions No connections are configured.
- iy
o g
o g
Assignment: LAN-1
Private-Mode: No
Link-Active: Yes
LAN4 * Connector: 100 Mbit Full-Cuplex
Auto-Negotiation: Completed
Flow-Control: Yes
MDI-Mode: MDIX
Network-name Server-Flags
DHCP INTRANET Client CHGP-Table
CNS Operating Yes Hit-List
Connection:
VPN Tunnel o
Ne connection available
State Setup
App none
S0-1-B1
Mode: unk.
Number.
ISDN 50-1: Deactivated (F2)
State Setup
App none
-1-B2
SotE Mode: unk.
Number:

Ifc Link-Active

DSL-1 No
DSLol DsL-2 No
DsLa No
DsSL4 No
Time Invalid time Set Oate and Time
Configured Networks
IP-Addresses INTRANET. 192.162.2.35
DMZ. 0.0.0.0

The amount of information shown on this screen can be defined under Setup/HTTP/Show device information. An
index number is also used to specify the display sequence.

% Setup Wizard,
7+ Setup Wizads LCOS Menu Tree

& System information
? Configuration
I‘_}% l t‘\enu Tree B Logout -
atus
EH setup LCOS Menu Tree
% gtr;nware & Setup
er &HTTP
[ File management
P Extras Show-device-information
A HTTP-Session
B Logout & Devicenformation cPy =
Q Position P\CAEIL“an {max. 10 chal

Ethernet-Forts
TroughputiEthernet)
UrTS/Moderm-Interface
Router

Firewall

DHCPE

DNS

VPN

ADSL

150N

DSLlol

Time

IP-Addresses

Operating-Time

Send Beset

LANCOM devices also store syslog information to the main memory (see Syslog). You can also view the latest syslog
entries in WEBconfig under "System information"”.
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A& Setup Wizards . .
& System information System information
‘? Configuration
LCOS Menu Tree [B Logout m
Status
inmware
FH ther ldx. Time Source  Level Iessage
[ File management 1 12/18/2008 16:35:21 LOCALO Enor  VPN: Eror for peer LCS: IFC- -Nochannel-available
‘? Extras 2 12/18/2008 16:35:21 LOCALO Enor  WPN: Enor for peer LOS: IFC- -Nochannel-available
[ HTTP-Session 3 12/18/2008 16:35:21 LOCALO Enor  WPN: Enor for peer LCS: IFC-l-No-polltable-entry-matched
@ Logout 4 12/18/2008 16:35:22 LOCALO Enor  WPN: Enor for peer LCS: IFC- -No-channel-available
5  12/18/2008 16:35:22 LOCALO Emor  VPN: Ermor for peer LCS: IFC-l-No<channel-available
6  12/18/2008 16:35:22 LOCALO Enor  VPN: Enor for peer LCS: IFC- -No-channel-available
7 12/18/2008 16:35:23 LOCALO Emor  VPN: Ermor for peer LCS: IFC-l-Nochannel-available
8 12/18/2008 16:35:23 LOCALO Enor  VPN: Eror for peer LCS: IFC- -No-channel-available
9 12/18/2008 16:35:24 LOCALO Enor  WPN: Enor for peer LOS: IFC- -Nochannel-available
10 12/18/2008 16:25:24 LOCALO Emor  VPN: Eror for peer LCS: IFC-l-No<channel-available
11 12/18/2008 16:35:25 LOCALO Enor  WPN: Enor for peer LCS: IFC- -No-channel-available
12 12/18/2008 16:25:25 LOCALO Emor  VPN: Eror for peer LCS: IFC-l-No<channel-available
13 12/18/2008 16:33:25 LOCAL2  Alaim Dst: 10.1.1.3:137 {los-en}, Sre: 192.168.145.1:137 (UDP): intrusion detection
14 12/18/2008 16:35:25 LOCAL3 Alamn Dst: 10.1.1.3:127 {les-en}. Src: 192,168,145, 1:137 (UDP): port filter
15 12/12/2008 18:25::25 LOCALO Enor  VPN: Eror for peer LCS: IFC- -Nochannel-available
16 12/18/2008 16:35:25 LOCALO Enor  WPN: Enor for peer LOS: IFC- -Nochannel-available
17  12/18/2008 16:35:25 LOCAL3 Alarm Dst: 10.1.1.3:137 {lcs-en}, Sre: 192.188.202.1:137 (UDP): intrusion detection
e T \ R o . - y
Configuration

Menu area “Configuration” provides the configuration parameters in the same structure as they are used in

LANconfig.

Please note that not all settings can be configured from this configuration view.

6 System information

# Configuration

W Management

- g Intertaces

G- o LaN

- [ Ethemet Ports
s WAN

&F Modem

o VLAN

B (D Date & Time
- ﬁ Log & Trace
B @& communication
B~ TCP/IP
Bl <5 1P Router
- Y Firewall/QoS
B @ veN

B @ Ceificates
[E

[E

£

[E

e

[E

[E

)5 Setup Wizards

H- g7 COM-Ports

- il IPX/SPX

- ol NetBIOS

- ol LANCAPI

- i Least-Cost-Router
- 7 VolP Call Manager
H- &5 Printer

- 9 LCOS Menu Tree

7 [y File management

e ? Extras

- [ HTTP-Session

L — B oonnt

E
&
e
L

Interfaces

& Logout

LAN WAN Modem VLAN

Ethernet Ports

Ethernet Port Interface usage Transfer mode MDI mode Private mode

LANCOM
Systems

...connecting your

ETH 1 LAN-1 Auto
ETH2 LaN-1 Auto
ETHa LAN-1 Auto
ETH4 LAN-1 Auto

Auto
Auto
Auto
Auto

ot
Off
off
ot

LCOS menu tree

Menu area “LCOS menu tree” provides the configuration parameters in the same structure as they are used under
Telnet. Clicking the question mark calls up help for each configuration parameter.

A Setup Wizards
@ System information
'# Configuration

LCOS Menu Tree

1 Status

E\E Setup

@ Firmware

bj Cther
[ File management
7 Extras
HTTP-Session
(B Logout

LCOS Menu Tree

[B Logout

LCOS Menu Tree
& Setup
5 Interdaces

Ethernet-Ports

& Port

(2] Assignment
@ Connector
@ MDI-Mode
@ Private-Mode

LAN-1

File management

The menu area “File management” contains all actions with which files are downloaded from the device and uploa-

ded to the device:

m Uploading new firmware
B Saving configuration
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B Uploading configuration
B Using configuration script
B Saving configuration script
B Uploading certificate or file
B Downloading certificate or file
T8 cretom tamaion File management LANCOM
-3 ',‘a’)nhguratlon Systems
B E%O;"?Emmee [E Logout ...cenmecting your busines
@Se{u\;
P Firmware Please choose the desired operation:
£ othe » iff Perform a Firmware Upload
E}' 'g E‘)‘;:“ag?mﬂ“ » I{ Save Confiquration
B [ HTTP-Session g gxzajecgg:ﬁugfrt::m Sciipt
it @' Logout » [ Save Confiquiation Script
» £ Upload Certificate or File
» & Download Certificate or File
Extras
The menu area "Extras" contains a few functions that simplify device configuration.
G Setup Wizards
e ‘S\;ltzm information Extras M
= ? Configuration Systems
E}?LCOSW‘NTV&E [B Logout e e e s

- By File management

- 2 Extras

& Search

& Get Device SNMP MIB

& ShowSearch Other Devices
@ Display Key Fingerprints

& Edit List of Allowed SSH Public Keys
s Craate TOP/HTTP Tunnel
<5 Enable Software Option

(©) Set Date and Time

) Change password

Plaase choose the desired menu entry:

* @ Search

« I Get Device SNMP MIB

» @ Show/Search Other Devices
» /3 Display Key Fingerprints

4 Edit List of Allowed SSH Public Keys

« < Create TCF/HTTF Tunnel
» . Enable Software Option
» () Set Date and Time

B Reboot * ) Change password
[ 5 HTTP-Session * T Reboot
— B | ooout

The search function can be used, for example, to search the names for all configuration parameters. If you know the
name for a particular configuration parameter, but do not know which menu is used to reach this entry, you can
quickly locate the required place in the LCOS menu in this way.

G 4 Setup Wizards

[~ 4 System information

- ? Configuration

[ 2 LCOS Menu Tree

- [§3 File management

- 3 Extras

& S=ach

I Get Device SNMP MIB

& Show/Search Other Devices
5 Display Key Fingerprints

& Edit List of Allowed SSH Public Keys
=4 Create TOP/HTTP Tunnel
<5 Enable Scftware Option

() Set Date and Time

ig Change password

B Reboot

[H- [ HTTP -Session

L =B s

Search Results

[ Logout

...tennecting

The following matches were found for your search term 'radius®:

LCOS Wenu Tree: StatusTCP-IP/RADIUS-Client

90%
config/1/813

LCOS Menu Tree: Setup\WAN/RADIUS

80%

config/2/2/22

LCOS Wenu Tree: Setup/RADIUS
90%
configi2/25

LANCOM

Systems

your busines

Using the Show/Search function, you can search for other LANCOM devices in your network and switch directly to
the configuration of the devices located via a corresponding link.

A Setup Wizards
@ System information
P Configuration
? LCOS Menu Tree
({4 File management
Extias
& Search
I Get Davice SNMP MIB
& Show/Search Other Devices
43 Display Key Fingerprints
@ Edit List of Allowed SSH Public Keys
f Create TCP/HTTP Tunnel
<4 Enable Software Option
() Set Date and Time
i Change password
B Reboot
- [ HTTP-Session

Show/Search Other Devices

B Logout

Below is a list of all devices found during the previous scans. Click onto the links to jump to a device's WEBconfig. You may also rescan the local of

P I e W O <L I}

a remote network with the buttons below the table.

Name Device Type Address Status
@g} Iy LANCOM LANCOM 1811 Wireless DSL 192.168.2.35 Ready

&9 VP-100-00405712 78 ANCOM VP-100 LANGOM VP-100

192.168.2.47 Ready

LANCOM

Systems

your busines

HTTP session

Menu area “HTTP session” allows you to customize the display of the WEBconfig interface to your output device for
improved readability, e. g. by lowering the resolution or increasing the contrast.
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A Setup Wizards

@ System information HTTP-Session L— 4 M:DM
 Configuration Systems
P LCOS Menu Tree [E Logout
(g File management
P Ext
1| HTTP -Session Please choose the used style for this session:
@ Logout

» || Switch to normal design
* [ Switch to design for small resolution:

* m Swiich to design with hight contrast

1.9  Configuration with other tools

1.9.1 Telnet

New with LCOS 7.6:
B Extended functions for editing commands
B Function keys

Open Telnet session

To commence the configuration, start Telnet from the Windows command line with command:
C:\>telnet 10.0.0.1

Telnet establishes a connection to the device with the IP address entered.

After entering the password (assuming one has been set to protect the configuration) all of the configuration com-
mands are available to you.

Linux and Unix additionally support Telnet sessions via SSL-encrypted connections.
Depending on the distribution it may be necessary to replace the standard Telnet application with an SSL-
capable version. Start the encrypted Telnet connection with the following command:

C:\>telnet -z ssl 10.0.0.1 telnets

Changing the console language

The terminal mode operates with the languages English and German. LANCOM devices are set with English as the
standard console language. If necessary, change the console language with the following commands:

WEBconfig: LCOS menu tree » Config-Module » Language

Close the Telnet session

To close the Telnet session, enter the command exit at the command prompt:

C:\>exit

Structure of the command- line interface

The LANCOM command-line interface is always structured as follows:

. Telnet 192.168.2.23

it

i LANCOM L-54ag Wireless

i Ver. 7.68.8123RC1 ~ 17.12.206088
i 8N. ©B88528688482

i Copyright <(c> LANCOM Systems

Connection No.: 882 (LAN>

| Status

Contains the status and statistics of all internal modules in the device
B Setup

Contains all adjustable parameters of all internal modules in the device
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Contains the firmware management

B Others

Contains actions for establishing and terminating connections, reset, reboot and upload.

Command-line commands

The LANCOM command-line interface can be operated with the following DOS- or UNIX-style commands. The LCOS
menu commands that are available to you can be displayed at any time by entering HELP at the command line.

@ Supervisor rights are necessary to execute some commands.

beginscript Resets the console session to script mode. In this state, commands entered are not transferred directly to the LANCOM's
configuration RAM but initially to the device's script memory.

cd [PATH] Switch to the current directory.
Various abbreviations can be used, such as replacing * cd ../.." with "cd ...", etc.

del [PATH]* Deletes the table in the branch of the menu tree defined with Path.

default [-r] [PATH]

Resets individual parameters, tables or entire menu trees back to their default configuration. If PATH indicates a branch of
the menu tree, then the option -r (recursive) must be entered.

dir [PATH]
list [PATH]
Is [PATH]
[l [PATH]

Displays the current directory content.

The suffix parameter "-a" lists the SNMP IDs associated with the content of the query. The output begins with the SNMP ID
of the device followed by the SNMP ID of the current menu. The SNMP IDs of the subordinate items can be read from the
individual entries.

do [PATH] [<Parameter>]

Executes the action [PATH] in the current directory. Other parameters can be entered in addition.

echo <ARG>...

Display argument on console

exit/quit/x

Ends the command line session

feature <code>

Activation of a software feature with the feature code as entered

flash Yes/No Changes to the configuration using commands in the command line are written directly to the boot-resistant Flash
memory of the devices as standard (flash yes). If updating the configuration is suppressed in Flash (flash no), changes are
only stored in RAM (deleted on booting).

history Displays a list of recently executed commands. Command “!#" can be used to directly call the list commands using their
number (#): For example, "13" runs the third list command.

killscript Deletes the script session contents yet to be processed. The script session is selected by its name.

loadconfig Load configuration into device via TFTP client

loadfirmware Load firmware into device via TFTP client

loadscript Load script into device via TFTP client

passwd Change password

passwd -n new [old]

Change password (no prompt)

ping [IP address or name]

Sends an ICMP echo request to the IP address specified

readconfig

Display of the entire configuration in the device syntax

readmib

Display of the SNMP Management Information Base

readscript [-n] [-d] [-c] [-m] [PATH]

In a console session, the readscript command generates a text dump of all commands and parameters required to confi-
gure the LANCOM in its current state.

repeat <INTERVAL> <Command>

Repeats the command every INTERVAL seconds until the process is ended with new input

sleep [-u] value[suffix]

Delays the processing of configuration commands by a particular time or terminates them at a particular time. Permissible
suffixes are s, m and h for seconds, minutes and hours. If no suffix is defined, the command uses milliseconds. With option
switch -u, the sleep command accepts times in format M/DD/YYYY hh:mm:ss (English) or in format TT.MM. 3337
hh:mm:ss (German). Date configuration is only accepted if the system time is set.

stop

Ends the PING command

set [PATH] <value(s)>

Sets a configuration parameter to a particular value.
If the configuration parameter is a table value, a value must be specified for each column.
Entering the "*" character leaves any existing table entry unchanged.

set [PATH] ?

Listing of the possible input values for a configuration parameter.
If no name is specified, the possible input values for all configuration parameters in the current directory are specified.

setenv <NAME> <VALUE>

Set environment variable

unsetenv <NAME>

Delete environment variable

getenv <NAME>

Display environment variable (no line feed)
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printenv

Display the entire environment

show <options>

Display of special internal data.

show ? displays all available information, such as most recent boot processes (‘bootlog’), firewall filter rules (‘filter’), VPN
rules ('VPN’) and memory usage (‘mem’ and "heap’)

sysinfo Display of system information (e.g. hardware/software version)

testmail Sends an e-mail. See 'testmail ?' for parameters

time Set time (DD.MM.YYYY hh:mm:ss)

trace [...] Configuration of the diagnostics display.

who List active sessions

writeconfig Load a new configuration file in the device syntax. All subsequent lines are interpreted as configuration values until two
blank lines occur

writeflash Load a new firmware file (only via TFTP)

Il Repeat last command

l<num> Repeat command <num> times

I<prefix> Repeat last command beginning with <prefix>

#<blank> Comment

B PATH:

O Path name for a menu or parameter, separated by / or \
O .. means one level higher
[0 . means the current level

B VALUE:

O Possible input value
O ""isa blank input value

m NAME:

O Sequence of characters (made up of _0..9A..2)
O First character cannot be a digit
[ Case insensitive

B All commands and directory/parameter names can be entered using their short-forms as long as they are unam-
biguous. For example, command “sysinfo” can be shortened to “sys” and "cd Management” to “c
ma”. Input “cd /s" is not valid, however, since it corresponds to both “cd /Setup” and "cd /Sta-

"

tus'.

B Names that contain spaces must be enclosed within quotation marks (“*).

B A command-specific help function is available for actions and commands (call the function with a question mark
as the parameter). For example, 'ping ?' shows the options of the integrated ping command.

B Enter "2 on the command line for a complete listing of the console commands available.

Functions for editing commands

The following commands can be used to edit commands on the command line. The “ESC key sequences” show (for
comparison) the shortcuts used on typical VT100/ANSI terminals

Up arrow ESCIA In the list of commands last run, jumps one position up (in the direction of older
commands).

Down arrow ESC[B In the list of commands last run, jumps one position down (in the direction of
newer commands).

Right arrow Ctrl-F ESC[C Moves the insert cursor one position to the right.

Left arrow Ctrl-B ESC[D Moves the insert cursor one position to the left.

Home or Pos1

Ctrl-A ESC[A ESC[17(

Moves the insert cursor to the first character in the line.

End

Ctrl-E ESC [F ESC OF ESC [4

Moves the insert cursor to the last character in the line.

Ins

ESC[ESC [

Switches between input and overwrite modes.

Del

Ctrl-D ESC <BS>ESC [3"

Deletes the character at the current position of the insert cursor or ends the Tel-
net session if the line is blank.
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erase <BS><DEL> Deletes the next character to the left of the insert cursor.

erase-bol Ctrl-U Deletes all characters to the left of the insert cursor.

erase-eol Ctrl-K Deletes all characters to the right of the insert cursor.

Tabulator Completes the input from the current position of the insert cursor for a command

or path of the LCOS menu structure:

| If there is only one possibility of completing the command/path, this is accepted
by the line.

| If there is more than one possibility of completing the command/path, this is
indicated by an audible sound when pressing the Tab key. Pressing the Tab key
again displays a list of all possibilities to complete the entry. Then enter another
character, for example, to allow unambiguous completion of the input.

| If there is no possibility of completing the command/path, this is indicated by
an audible sound when pressing the Tab key. No further actions are run.

Function keys for the command line
B Telnet: Setup » Config » Function keys

The function keys enable the user to save frequently used command sequences and to call them easily from the com-
mand line. In the appropriate table, commands are assigned to function keys F1 to F12 as they are entered in the
command line.

B Key
Name of function key.
Possible values:
0 Selection from function keys F1 to F12.
Default:
O F1
B Mapping
Description of the command/shortcut to be run on calling the function key in the command line.
Possible values:
0 All commands/shortcuts possible in the command line
Default:
O Blank
Special values:
O The caret symbol A is used to represent special control commands with ASCII values below 32.7a
O AA stands for Ctrl-A (ASCII 1)
O AZstands for Ctrl-Z (ASCII 26)
0 A[ stands for Escape (ASCII 27)
O AA Adouble caret symbol stands for the caret symbol itself.

If a caret symbol is entered in a dialog field or editor followed directly by another character, the operating

@ system may possibly interpret this sequence as another special character. A Windows operating system
makes, for example, an A from input caret symbol + A. To call the caret symbol itself, enter a space before
the following character. Sequence *A is then formed from caret symbol + space + A.

1.9.2 SNMP
The Simple Network Management Protocol (SNMP V.1 as specified in RFC 1157) allows monitoring and configuration
of the devices on a network from a single central instance.

There are a number of configuration and management programs that run via SNMP. Commercial examples are Tivoli,
OpenView from Hewlett-Packard, SunNet Manager and CiscoWorks. In addition, numerous programs also exist as
freeware and shareware.

Your LANCOM can export a so-called device MIB file (Management Information Base) for use in SNMP programs.
WEBconfig: Extras »Get Device SNMP MIB

1.9.3  Encrypted configuration with SSH access

In addition to the option to configure a LANCOM with Telnet or a terminal program, LCOS version 4.00 and later
provides an additional option of access via SSH. With a suitable SSH client such as PuTTy, you can set up an encrypted
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connection to the device and thus prevent the data being transferred during configuration from being intercepted
within the network.

Start PuTTy (for example) and enter the LANCOM device's IP address as the host name. Use the command prompt
that follows to log in by entering your user data.

% PUTTY Configuration = |

Category:

- S_ession | Basic options for your PuT T seszion
- Logging
- Terminal

Host Mame [or IP address) Port
J192.166.2.100) |22
Fratacal:

" Raw " Telnet ¢ Rlogn & SSH

i~ Load. save or delete a stored session
Saved Sessions

VPN _MNHAMEL, Connection MNo.: 002 (LAN)

Drefault Settings Load

Save | PN_WHAMEL:/

Alternatively, you can use LANconfig under Tools » Options » Extras to enter your SSH client as an "external pro-
gram”; then start the SSH access with a right-mouseclick on the device and open WEBconfig/Console session »
Open SSH session.

options 20X

Generall Startupl Windows  Extras |

— Set up new device

@ ¥ Launch Setup Wizard when a new

unconfigured device iz found #%i LANconfig
File Edit Device WYiew Tools Help
i~ External program = - =
- _ S| mlwlE| 2l sl Elklals wlelsl 22
Sl Telnet client: Itelnet.exe — -
@ ) Mame Description Address Device Status Progress
S5H client: ID:\Programme\LANEDM\putty. s H 197 168,2,100 Ok
Configure Enter
Setup Wizard Chrl+iw
Check Chrl+FS
Configuration Managenent 3 |
Firmware Managemenkt 3
WEEconfig / Console session Open \Web Browser
P Py Open secure Web-Browser  Chrl+E
onior bevice i Open Telnet Session Chrl+T

Set DatefTime ...
Activate Software Option

Open 55H Sessio Chrl+5Shift+5

The configuration is carried out with the same commands as used under Telnet or other terminal program ('Com-
mand line reference” — page 33).

1.9.4 SSH authentication

The SSH protocol generally allows two different authentication mechanisms:
B With user name and password
m With the help of a public key

In the public key method, a key pair is used that is made up of a private and public key — a digital certificate. Detailed
information about the keys mentioned here can be found under the section 'Digital certificates' in the chapter on
VPN in the reference manual. The private part of the key pair is saved on the client (frequently protected with a pass-
word), the public part is loaded into the LANCOM Router.

The LANCOM Router supports both RSA and DSS/DSA keys. RSA keys are somewhat smaller, thereby allowing some-
what faster operation.

Generating key pairs

The pairs consisting of public and private keys can be generated with the help of OpenSource software OpenSSH,
for example. The following command from a Linux operating system creates a key pair from the public part
'id_rsa.pub' and the private part 'id_rsa"

ssh-keygen -t rsa

Entering users into the public key

The public keys are generated in the following syntax:
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<Encryption algorithm> <Public key> <User> [Further users]

In order to grant access to additional users with this key, the respective user names are simply attached to the exis-
ting key file.

Installing the private key on the SSH client

The private part of the key must be installed on the SSH client. Refer to the documentation for information on the
steps required for your SSH client.

Load public key into the LANCOM Router

The public key(s) can be uploaded to the LANCOM Router using WEBconfig. For this, select the entry Upload cer-
tificate or file on the WEBconfig start page. In the following dialog, select the type of key ('SSH RSA key' or 'SSH
DSA key'), select the file and enter the password if required. Entering the Upload command initiates the transfer to
LANCOM.

The uploaded file replaces an existing list of accepted keys in the device. Another way is to choose the entry
edit list of allowed puplic keys at the start page og WEBconfig and edit the key directly. You can as well
edit single keys to the existing list.

Configuring the authentication methods
The authentication methods permitted for SSH access can be set separately for LAN, WAN and WLAN.

WEBCconfig, Telnet LCOS menu tree > Setup > Config > SSH authentication methods

B Methods
0 All: Allows authentication using password and digital certificate.
0 Password: Allows authentication with a password.
O Public key: Only allows authentication with a digital certificate.

Certificate check on SSH access

When establishing the SSH connection, the client first asks the LANCOM Router which authentication methods are
permitted for this connection. If the public key method is allowed, the client searches for private keys that have been
installed and transfers these with the user name to the LANCOM Router. When the LANCOM Router finds an entry
in the list that includes the user name that corresponds to its public SSH key, the SSH connection is permitted. If the
client does not have a suitable private key installed or if the LANCOM Router does not have a corresponding entry
with the user name or public key, the SSH client can revert to authentication with user name/password — as long as
this authentication method is permitted.

1.9.5 ISDN Remote configuration via Dial-Up Network

The complete section on remote configuration applies only to LANCOM with ISDN interface or a serial inter-
face (with LANCOM Modem Adapter Kit).

Configuring routers at remote sites is particularly easy using the remote configuration method via a Dial-Up Network
from Windows. The device is accessible by the administrator immediately without any settings being made after it is
switched on and connected to the ISDN interface. This means that you save a lot of time and costs when configuring
at separate locations because you do not have to travel to the other network or instruct the staff on-site on confi-
guring the router.

You can also reserve a special calling number for remote configuration. Then the support technician can always
access the router even if it is really no longer accessible due to incorrect settings.

This is what you need for ISDN remote configuration

H An LANCOM with an ISDN connection

B A computer with a PPP client, e.g. Windows Dial-Up Network

B A program for inband configuration, e.g. LANconfig or Telnet

B A configuration PC with an ISDN card or access via LANCAP/to an LANCOM with ISDN access.

The first remote connection using Dial-Up Networking
For the remote connection of a LANCOM with LANconfig using Dial-Up Networking proceed as follows:
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LANCOM with ISDN-inter- PC with Dial-Up Networ-

face for the configuration king, ISDN adapter (alter-
natively access to LANCAPI)
and LANconfig

(D In the LANconfig program select Device » New, enable 'Dial-Up connection' as the connection type and enter
the calling number of the ISDN interface to which the LANCOM is connected. If you wish, you can also enter the
time period after which an idle connection is to be disconnected automatically.

(2 LANconfig now automatically generates a new entry in the Dial-Up Network. Select a device that supports PPP
(e.g. the NDIS-WAN driver included with the LANCAPI) for the connection and press OK to confirm.

(3@ Then the LANconfig program will display a new device with the name 'Unknown' and the dial-up call number
as the address in the device list.

When an entry in the device list is deleted, the related connection in the Windows Dial-Up Network is also
deleted.

@ You can configure the device remotely just like all other devices. LANconfig establishes a dial-up connection
enabling you to select a configuration.

Always provide additional protection for the settings of the device by setting a password by switching to the
@ ‘Security' tab in the '"Management' configuration section.
The first remote connection using a PPP client and Telnet

Instead of a remote configuration with LANconfig it is also possible to access over ISDN with Telnet. For a remote
configuration of a LANCOM with Telnet over any PPP client proceed as follows:

LANCOM with ISDN-inter- PC with Dial-Up Networ-

face for the configuration king, ISDN adapter (alter-
natively access to LANCAPI)
and LANconfig

(D Establish a connection to the LANCOM with your PPP client using the following details:

O User name '‘ADMIN'
O The password selected in LANCOM
O An IP address for the connection, only if required

(2 Open a Telnet session to the LANCOM. Use the following IP address for this purpose:

0O '172.17.17.18', if you have not defined an IP address for the PPP client. The LANCOM automatically uses
this address if no other address has been defined. The PC making the call will respond to the IP
17217177,

O Raise the IP address of the PC by one, if you have defined an address. Example: You have set the IP
'10.0.200.123" for the PPP client, the LANCOM then responds to '10.0.200.124". Exception: If the digits
'254" are at the end of the IP address, the router responds to 'x.x.x.1".

(3@ You can configure the LANCOM remotely just like all other devices.

Always provide additional protection for the settings of the device by setting a password. Alternatively, enter
@ the following command during a Telnet or terminal connection:

passwd

You will then be prompted to enter and confirm a new password.
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The default layer for remote field installations

The PPP connection of any other remote site to the router, of course, will only succeed if the device answers every
call with the corresponding PPP settings. This is the case using the factory default settings because the default pro-
tocol (default layer) is set to PPP.

You may, however, want to change the default layer for LAN-to-LAN connections, for example, to a different protocol
after the first configuration run. Then the device will no longer take calls on the dial-up connection using the PPP
settings. The solution to this is to agree upon a special calling number for configuration access:

The administrator access for ISDN remote management

If the device receives a call on this number, it will always use PPP, regardless of any other settings made on the router.
Only a specific user name which is automatically entered by the LANconfig program during call establishment will
be accepted during the PPP negotiations:

(1) Switch to the 'Admin’ tab in the 'Management' configuration section.

45 YPN_NHAMEL Configuration 2=l
Configure: I M anagement = l
General  Admin |Eosts I %

r— Device Configuration

Main device password: lxxxxmx—
Nurnber [MSH): 123458

Further Administratars ... |

™ Password required for SNMP read permiszsion

— Configuration login lock

Lock configuration after: |5 login failures
Lock configuration far: |5 minutes

r— Configuration access way:

Here you can specify the access rights for each network and
each supported configuration protocol separately. In addition
you can limit access to the unit to certain stations.

Access rights - | Access stations ... |
LANESOM 0K I Cancel |
Systens

(2 Enter a number (MSN) at your location which is not being used for other purposes in the 'Device Configuration'
area.

Alternatively, enter the following command:

set /setup/config/Farconfig 123456

As long as no MSN is entered for the configuration access, a non-configured LANCOM accepts the calls on
all MSNs. As soon as the first change is saved in the configuration, the device only takes calls on the confi-
gured MSN!

If no MSN configuration is entered the remote access is switched off and the device is protected against
access over ISDN.

1.10 Working with configuration files

The current configuration of an LANCOM can be saved as a file and reloaded in the device (or in another device of
the same type) if necessary.

Additionally, configuration files can be generated and edited offline for any LANCOM device, firmware option and
software version:
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New Configuration File 21x
& Select the device that you want ko create a new
Q caonfiguration File for,
Device bype: LAMCOM 1621 ADSLIISDN

Firmware version: |3.DD d

Software options:  |_Leased line < ”
[ WPM (1 connection) =
[IWPN (25 conmections) Open With »
Run

Backup copies of configuration
With this function you can create backup copies of the configuration of your LANCOM.

Convenient series configuration

However, even when you are faced with the task of configuring several LANCOM of the same type, you will come to
appreciate the function for saving and restoring configurations. In this case you can save a great deal of work by
first importing identical parameters as a basic configuration and then only making individual settings to the separate
devices.

Running function
LANconfig:

Device » Configuration Management » Save to File
Device » Configuration Management » Restore from File
Edit » New Configuration File

Edit » Edit Configuration File

Device » Configuration Management » Print ...

WEBconfig: Save Configuration » Load Configuration (in main menu)

1.11  New firmware with FirmSafe

New with LCOS 7.60:
B Asymmetric firmsafe

1.11.1 This is how FirmSafe works

FirmSafe makes the installation of the new software safe: The used firmware is not simply overwritten but saved
additionally in the device as a second firmware. Therewith your device is protected against the results of a power
blackout or a disconnection while installing the firmware.

Of the two firmware versions saved in the device only one can ever be active. When loading a new firmware version
the active firmware version is not overwritten. You can decide which firmware will be activated after the upload:

B 'Immediate’: The first option is to load the new firmware and activate it immediately. The following situations
can result:

O The new firmware is loaded successfully and works as desired. Then all is well.

O The device no longer responds after loading the new firmware. If an error occurs during the upload, the
device automatically reactivates the previous firmware version and reboots the device.

B 'Login': To avoid problems with faulty uploads there is the second option with which the firmware is uploaded
and also immediately booted.

O In contrast to the first option, the device will wait for the adjusted firmsafe timeout (using WEBconfig in the
menu LCOS menu tree » Firmware » Timeout-firmsafe, using Telnet adjust with 'Firmware/Timeout-
firmsafe") until it is logged on over Telnet, a terminal program or WEBconfig. Only if this login attempt is
successful does the new firmware remain active permanently.

0 If the device no longer responds or it is impossible to log in, it automatically loads the previous firmware
version and reboots the device with it.

B 'Manual': With the third option you can define a time period during which you want to test the new firmware
yourself. The device will start with the new firmware and wait for the preset period until the loaded firmware is
manually activated and therefore becomes permanently effective. Activate the new firmware using LANconfig
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with Device » Firmware Management » Activate Firmware running in Test Mode, using Telnet under
‘firmware/firmsafe table' with the command 'set # active’ (#is the position of the firmware in the firmsafe table).
Using WEBconfig you can find the firmsafe table under LCOS menu tree»> Firmware.

The modus for the firmware upload can be adjusted using WEBconfig in the menu LCOS menu tree » Firmware
» Mode-firmsafe, using Telnet under ‘firmware/timeout firmsafe'. Using LANconfig select the modus when selec-
ting the new firmware file.

LIt is only possible to upload a second firmware, if the device has enough memory for two firmware versions.
Current firmware versions (in occasion with additional software options) may use up more than half of the
available memory. In this case the asymmetric firmware is used.

1.11.2 Asymmetric Firmsafe

Because of large range of functions in the firmware, some models are unable to simultaneously store two complete
versions of the firmware. These devices use the asymmetric Firmsafe. Here, the device always contains a complete
version and a minimal version of the firmware. The minimal version normally remains unused, but it allows local
access to the device after a failed upload of the complete firmware version (e.g. as a result of a power cut during the
upload process) so as to load an executable version of the firmware onto the device. The minimal firmware can not
be configurated. Changes in the configuration over LANconfig, WEBconfig or Telnet are not saved in the device
Advanced functions, such as remote administration, are not available whilst the minimal firmware is active. However,
the LL2M server is also active in a minimal firmware version and offers access to the device provided it is reachable
from an LL2M client over layer 2 (Ethernet).

Switching over to asymmetric Firmsafe

To switch devices to asymmetric Firmsafe, converter firmware is first loaded onto the device. This converts the firm-
ware currently not activated in the device into a minimal firmware version, creating room for new and more com-
prehensive firmware. This process only has to be performed once.

You can then load a new, complete firmware version onto the device, which becomes active after a successful upload.
The minimal firmware remains in the device to ensure that the device can be accessed.

Firmware upgrade with asymmetric Firmsafe

The subsequent firmware upload automatically overwrites the active firmware with new firmware.

1.11.3 How to load new software

There are various ways of carrying out a firmware upload, all of which produce the same result:
B LANconfig

WEBconfig

Terminal program

TFTP

%l All settings will remain unchanged by a firmware upload. All the same you should save the configuration first
for safety's sake (with Device » Configuration Management » Save to File if using LANconfig, for
example). Before uploading you should also save a version of the current firmware. If you do not have the
firmware as a file, you can download it from www.lancom.de.

If the newly installed release contains parameters which are not present in the device's current firmware, the device
will add the missing values using the default settings.

LANconfig

@l When using LANconfig, highlight the desired device in the selection list and click on Device » Firmware
Upload, or click directly on the Firmware Upload button. Then select the directory in which the new version
is located and mark the corresponding file.

LANconfig then tells you the version number and the date of the firmware in the description and offers to upload
the file. The firmware you already have installed will be replaced by the selected release by clicking Open.

You also have to decide whether the firmware should be permanently activated immediately after loading or set a
testing period during which you will activate the firmware yourself. To activate the firmware during the set test
period, click on Edit » Firmware Management . After upload, start the new firmware in test mode.
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2%
Look in: | £ Ie5.330 -] e @k E

= Lc-1621-3.30.upx

File name: ILE-1B21-3.30.upx Open [: I
Files of type: IFirmware Files j Cancel |

Description:  Firmware update, version 3.30 of 1/26/2004

[V After upload, start the new fimware in test mode
*r'ou have to activate the fimware explicitly within |5 _|::' minutes,

of the device will boot and then restart the previously activated firmware.

4

WEBconfig

Start WEBconfig in your web browser. On the starting page, follow the Perform a Firmware Upload link. In the
next window you can browse the folder system to find the firmware file and click Start Upload to start the instal-
lation.

Terminal program (e.g. Telix or Hyperterminal in Windows)

If using a terminal program, you should first select the 'set mode-firmsafe' command on the ‘Firmware' menu and
select the mode in which you want the new firmware to be loaded (immediately, login or manually). If desired, you
can also set the time period of the firmware test under 'set Timeout-firmsafe'.

Select the 'do Firmware-upload' command to prepare the router to receive the upload. Now begin the upload pro-

cedure from your terminal program:

m If you are using Telix, click on the Upload button, specify ‘XModem' for the transfer and select the desired file
for the upload.

B If you are using Hyperterminal, click on Transfer » Send File, select the file, specify 'XModem' as the protocol
and start the transfer with OK.

@ The firmware upload over a terminal program is only possible over a serial configuration interface.

T

TFTP can be used to install new firmware on LANCOM. This can be done with the command (or target) writeflash.
For example, to install new firmware in a LANCOM with the IP address 10.0.0.1, enter the following command under
Windows 2000 or Windows NT:

tftp -1 10.0.0.1 put Lc_16xxu.282 writeflash

Firmware upload via the serial interface with configuration reset

The serial interface can also be used to load firmware into the device. Entering the serial number instead of the con-
figuration password results in the device configuration being reset to its ex-factory settings. In this way you can re-
open the device in the case that the configuration password is lost and the reset button has been set to ‘Ignore’ or
'‘Boot only'.

(1) Use the serial configuration cable to connect the device to a computer.

(2 On the computer, start a terminal program such as Hyperterminal.

(3 Open a connection with the settings 115200bps, 8n1, hardware handshake (RTS/CTS).

@ In the terminal program's welcome screen, press the Return key until the request to enter the password appears.

(5 Enter the serial number that is displayed under the firmware version and press Return again.
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Outband-115200 Bit/s OK

#
LANCOM L-54ag Wireless
Ver. 7.26.0002 / 19.09.2007
SN, 013020600159
Copyright {c) LANCOM Systems

Connection Mo.: 001 {Outband-115200 Bps)

Password:

System is going down ...
He

FLASHROK-Up1 oad

LANCOM L-54ag Wireless

Copyright (C) LANCOM Systems

Ver. 2.06.0001 / 22112006 / 16:30

|
|
|
gtart Kmodem Upload

[Cannected 0:01:41 [putodetect  [1152008-N-1  [SCROLL  [CAPS  [uom  [Capture  [Print echo

(® The device now expects a firmware upload. To initiate this, in Hyperterminal you click on Transfer » Send file
and select X-Modem as the transfer protocol.

Uploading the firmware in this way completely deletes the configuration, which is returned to its ex-factory
@ settings! Consequently, this option should only be used if the configuration password is no longer available.

1.12  Load files directly from a TFTP or HTTP server into the device

New in LCOS 7.60:
B Specification of server, path and file in URL notation
B Loading files into the device from an HTTP(S) server

Certain functions cannot be run satisfactorily, or not at all, via Telnet. These functions include those where entire files
are transferred, such as the upload of firmware, and saving or restoring configuration data. TFTP or HTTP(S) is used
in these cases.

1.12.1 TFTP

TFTP is available in Windows operating systems as standard. It enables the simple transfer of files to/from other
devices over the network.

The syntax of the TFTP call is dependent on the operating system. The syntax under Windows:

tftp -1 <IP address Host> [get|put] source [destination]

The ASCII format is pre-configured on many TFTP clients. Binary transmission therefore usually needs to be
selected explicitly for the transfer of binary data (suchas firmware). Parameter "-i' is used for this in this
example under Windows.

If the device is password-protected, user name and password must be included in the TFTP command. The file name
is either made up of the master password and the command to be executed (for supervisors), or of the combined
user name and password separated by a colon (for local administrators), with the command as a suffix. A command
sent by TFTP therefore resembles the following:

B <Master password><Command> or

B <User name>:<Password>@<Command>

The rights to use TFTP can be restricted for administrators—see also “Managing rights for different administrators”.

1.12.2 Loading firmware, device configuration or script via HTTP(S)

By supporting HTTP and in particular HTTPS, downloads of firmware, device configurations or scripts can also be used
by LANCOM devices for automated processes (e.g. self-provisioning) that source files from the Internet. In practice
it is far simpler to provide a cental HTTPS server with a unique Internet address (URI) than a comparable TFTP server,
and an existing Web server can be modified to offer this function.

A certificate used optionally for the HTTPS server is uploaded by WEBconfig to the device as the SSL root CA certifi-
cate:
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A Setup Wizards ) .

@ System information Upload Certificate or File L A N c D M
? Configuration Systems

# LCOS Menu Tree [ Logout

[ File management
P Extras
[EHTTP-Session

B Logsit Upload Certificate or File
ogouf

Select which file you want to upload, and its name/lecation, then click on ‘Start Upload':

File Type: I S5L - Cerificate (* perm, *.ct *.car [BASERA]) ;]

File Name/Location: Durchsuchen..
Passphrase (if required): sssssssss

Caution: Files are not being checked for correct contents or passphrase during upload. These checks are performed by the individual medules usin,
these files. When uploading certificates. possible enor messages can be seen in the VPN status trace immediately after download.

1.12.3 Loading firmware, device configuration or script via HTTP(S) or TFTP

Along with the option to load firmware or a configuration file into a device using LANconfig or WEBconfig, Telnet
and SSH can also be used to directly upload the relevant files from an HTTP(S) or TFTP server. This process can simplify
device administration in larger installations with regular firmware update and/or configuration. HTTP(S) and TFTP
can also be used to load scripts (e.qg. with partial configurations) into devices.

For this, the firmware and configuration files or scripts are stored on an HTTP(S) or TFTP server. A TFTP server is iden-
tical to an FTP server in terms of functionality, but uses a different protocol for data transmission. When using an
HTTPS server, a certificate used to check the identity of the server can be stored on the device. The files can be retrie-
ved from this server with the following commands:
B LoadConfig
B LoadFirmware
B LoadScript
The server, the directory and the file can be specified in two ways:
B By using the TFTP protocol with parameters -s and -f.

00 -s <Server IP address or server name>

00 -f <File path and file name>

B Touse TFTP or HTTP(S), the command can be specified in the usual URL notation (either TFTP or HTTP(S) is entered
as the protocol):

0 Command protocol://server/directory/file name
When accessing a password-protected area on an HTTP(S) server, user name and password are entered accor-
dingly:
00 Command protocol://user name:password@server/directory/file name
When using HTTPS, a certificate can be specified with which the identity of the server is checked.
00 -c <Certificate name>

The following variables are permitted in the file name (including path):

%m - LAN MAC address (hexadecimal, lowercase, no separators)

%s - Serial number

%n - Device name

%I - Location (from the configuration file)

%d - Device type

Examples:

The following Telnet command loads a firmware file named 'LC-1811-5.00.0019.upx" into the device from directory
'LCOS/500" on the server with IP address '192.168.2.200":

B LoadFirmware -s 192.168.2.200 -f LCOS/500/LC-1811-5.00.0019.upx

The following command in a Telnet session loads a script consistent with the MAC address from the server with IP
address '192.168.2.200" into the device:

B LoadScript -s 192.168.2.200 -f %m.lcs

The following command in a Telnet session loads into the device a firmware file named 'LC-1811-5.00.0019.upx’
from directory ‘download' on the HTTPS server with IP address ‘'www.myserver.com'. The identity of the server is che-
cked with the “sslroot.crt” certificate.

B LoadFirmware -c sslroot.crt https://www.myserver.com/download/LC-1811-5.00.0019.upx

If the parameters -s and/or - f are not specified, the device uses default values set in path /setup/config/TFTP-
Client:
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Config address
Config file name

Firmware address

Firmware file name

These default values can be used if the latest configurations and firmware versions are always stored under the same
name in the same location. In this case, the simple commands LoadConfig and LoadFirmware can be used to
load the relevant files.

1.13 How to reset the device?

If you have to configure the device regardless of possible existing settings, or if a connection to the device configu-
ration failed, you can put back the device into the factory default state with a Reset. To do so, push the Reset but-
ton until the device LEDs will light up (approx. 5 seconds).

Reset switch (according to the model type

@/@M on the front or rear panel)

Config(COM) Reset Antenna Main| & €

After applying the reset, the device will start fresh with factory defaults. All settings will be lost. Therefore,
you should save the current configuration if possible before the reset!

Please notice that also the WLAN encryption settings of the device will get lost in case of a reset and the
standard WEP key comes into effect again. The wireless configuration of a device with WLAN interface will
only succeed after a reset, if the standard WEP key is programmed into the WLAN adapter!

The reset button offers two basic functions—boot (restart) and reset (to the factory settings)—which are called by
pressing the button for different lengths of time.

Some devices simply cannot be installed under lock and key. There is consequently a risk that the configuration will
be deleted by someone pressing the reset button too long. With the suitable setting, the behavior of the reset button
can be controlled accordingly (only for devices with serial configuration interface):

WEBconfig: LCOS Menu Tree P> Setup P> Config
B Reset button
This option controls the behavior of the reset button when it is pressed:

O Ignore: The button is ignored.

Please observe the following notice: The settings 'Ignore’ or '‘Boot only' makes it impossible to reset the

@ configuration to the factory settings using the reset button. If the password is lost for a device with this set-
ting, there is no way to access the configuration! In this case the serial communications interface can be
used to upload a new firmware version to the device-this resets the device to its factory settings, which
results in the deletion of the former configuration. Instructions on firmware uploads via the serial configu-
ration interface are available here (— Seite 1-44).

O Reset-or-boot (standard setting): Press the button briefly to restart the device. Pressing the button for 5
seconds or longer restarts the device and resets the configuration to its factory settings. All LEDs on the
device light up continuously. Once the switch is released the device will restart with the restored factory set-
tings.

After applying the reset, the device will start fresh with factory defaults. All settings will be lost. Therefore,
you should save the current configuration if possible before the reset!

Please notice that also the WLAN encryption settings of the device will get lost in case of a reset and the
standard WEP key comes into effect again. The wireless configuration of a device with WLAN interface will
only succeed after a reset, if the standard WEP key is programmed into the WLAN adapter! After a reset, the
LANCOM access point returns to managed mode, in which case the configuration cannot be directly
accessed via the WLAN interface!

SIS,
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